Bug 1255476 - keystoneclient `user-get` unable to handle usernames containing utf-8 characters [NEEDINFO]
keystoneclient `user-get` unable to handle usernames containing utf-8 characters
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-keystoneclient (Show other bugs)
5.0 (RHEL 6)
All Linux
high Severity high
: zstream
: 8.0 (Liberty)
Assigned To: Harry Rybacki
Prasanth Anbalagan
: Triaged, ZStream
Depends On: 1226860 1255477 1255479 1335981
Blocks: 1335980
  Show dependency treegraph
 
Reported: 2015-08-20 12:53 EDT by Scott Lewis
Modified: 2018-03-15 08:37 EDT (History)
14 users (show)

See Also:
Fixed In Version: python-keystoneclient-1.7.2-2.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1226860
: 1335980 (view as bug list)
Environment:
Last Closed: 2018-03-15 08:37:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ccollett: needinfo? (hrybacki)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1465500 None None None Never
OpenStack gerrit 192104 None None None Never
Red Hat Product Errata RHBA-2018:0532 None None None 2018-03-15 08:37 EDT

  None (edit)
Comment 6 Prasanth Anbalagan 2018-02-23 09:04:42 EST
[stack@undercloud-0 ~]$ source overcloudrc 
[stack@undercloud-0 ~]$ keystone user-create --name ñew --tenant admin
+----------+----------------------------------+
| Property |              Value               |
+----------+----------------------------------+
|  email   |                                  |
| enabled  |               True               |
|    id    | c6a8d83ee6c24ebebe8839e3504936f2 |
|   name   |               ñew                |
| tenantId | 9659e8dce8234c188dd964d8aa4358ad |
| username |               ñew                |
+----------+----------------------------------+
[stack@undercloud-0 ~]$ keystone user-get ñew
+----------+----------------------------------+
| Property |              Value               |
+----------+----------------------------------+
|  email   |                                  |
| enabled  |               True               |
|    id    | c6a8d83ee6c24ebebe8839e3504936f2 |
|   name   |               ñew                |
| tenantId | 9659e8dce8234c188dd964d8aa4358ad |
| username |               ñew                |
+----------+----------------------------------+
[stack@undercloud-0 ~]$ 
[stack@undercloud-0 ~]$ yum list installed | grep python-keystoneclient
python-keystoneclient.noarch     1:1.7.2-2.el7ost       @rhelosp-8.0-puddle
Comment 10 errata-xmlrpc 2018-03-15 08:37:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0532

Note You need to log in before you can comment on or make changes to this bug.