Bug 1255480 - upstream fix for bug 55397 is needed to get Polarion supported on RHEL7
upstream fix for bug 55397 is needed to get Polarion supported on RHEL7
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: httpd (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Web Stack Team
Martin Frodl
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-20 13:00 EDT by Cameron Meadors
Modified: 2015-11-18 23:38 EST (History)
3 users (show)

See Also:
Fixed In Version: httpd-2.4.6-39.el7
Doc Type: Bug Fix
Doc Text:
Cause: After the update to httpd 2.4.x, mod_dav started treating internal representation of URI as uri-encoded. However, mod_dav_fs did not uri-encode this internal URI reprensetation while mod_dav_svn did. Consequence: This leads to double encoding when using mod_dav with mod_dav_svn. This breaks some versions of Subversion clients when using paths which need encoding and httpd 2.4.x. Fix: Encoding part has moved from mod_dav to mod_dav_fs. Result: Subversion clients now works when used with paths which need encoding.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-18 23:38:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cameron Meadors 2015-08-20 13:00:23 EDT
We need the bug fix in this upstream bug

https://bz.apache.org/bugzilla/show_bug.cgi?id=55397

to have Polarion supported on RHEL7.  This is the only issue blocking that support.
Comment 8 errata-xmlrpc 2015-11-18 23:38:59 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2194.html

Note You need to log in before you can comment on or make changes to this bug.