Bug 1255494 - [RFE] Allow configure max-threads and core-threads independently
[RFE] Allow configure max-threads and core-threads independently
Status: CLOSED NOTABUG
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: EJB (Show other bugs)
TBD EAP 6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Panagiotis Sotiropoulos
Jan Martiska
:
Depends On:
Blocks: 1106790
  Show dependency treegraph
 
Reported: 2015-08-20 14:13 EDT by Ricardo Martinelli de Oliveira
Modified: 2016-03-24 19:37 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-24 19:36:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker PRODMGT-1401 Major Resolved Fine-grained control on ejb3 thread-pool and reuse idle threads in pool before creating new 2017-06-21 03:37 EDT
JBoss Issue Tracker WFLY-5332 Major Pull Request Sent Allow configure max-threads and core-threads independently. Allow idle thread reusage. 2017-06-21 03:37 EDT

  None (edit)
Description Ricardo Martinelli de Oliveira 2015-08-20 14:13:27 EDT
Description of problem:
It looks like the ejb3 subsystem thread pool configuration is hard coded to create an unbounded thread pool, where it it looks like max-threads = core-threads, and thus the threads will increase up to the max-threads configured and then remain there.  The keep-alive setting which appears in many of the docs & default configurations is ineffective since max=core.

ejb3/src/main/java/org/jboss/as/ejb3/subsystem/EJB3SubsystemRootResourceDefinition.java

I tried defining a different thread pool in the threads subsystem and tried to reference it from the ejb3 subsystem, however it looks like the ejb3 subsystem only looks for thread pools configured in the ejb3 subsystem.

Version-Release number of selected component (if applicable):
6.x
Comment 1 Ricardo Martinelli de Oliveira 2015-09-15 14:04:53 EDT
Complementing information to this bugzilla:

"the desired functionality is to, when a new request arrives
and there is an idle thread, use that thread instead of creating a new 
thread [up until max-threads]."
Comment 3 Lyle Wang 2015-09-15 21:03:54 EDT
Jira PRODMGT-1401 created to address the new requirement customer is asking for 
--------------------
"the desired functionality is to, when a new request arrives
and there is an idle thread, use that thread instead of creating a new 
thread [up until max-threads]."
--------------------

as well as including the info. in WFLY-5332
Comment 4 Panagiotis Sotiropoulos 2015-09-16 09:46:38 EDT
The creation of a new ThreadPoolExecutor is required.
Comment 17 Brad Maxwell 2016-03-24 19:36:28 EDT
This is an RFE not a but, the RFE for it is : PRODMGT-1401 , closing the bz as the rfe will be handled via PRODMGT-1401

Note You need to log in before you can comment on or make changes to this bug.