Bug 1255529 - Fedora reinstall fails on Lenovo W541 [NEEDINFO]
Fedora reinstall fails on Lenovo W541
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
22
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-20 16:19 EDT by Donald Berry
Modified: 2015-09-11 10:08 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-28 15:35:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dberry: needinfo? (anaconda-maint-list)


Attachments (Terms of Use)

  None (edit)
Description Donald Berry 2015-08-20 16:19:02 EDT
Description of problem:
Trying to reinstall Fedora 22.  The initial install worked fine.  Running the installer now gives me a blank screen with a flashing cursor in the top left corner.  I tried running the F22 Live CD, and I got an error "uncompression error, --system halted".  I found some threads that suggested it was a memory error, so I tried running Memtest from the GRUB menu, and the laptop immediately restarted.

The netinstall USB is the same one I used to do the original install, so I know it is OK.
The Live CD USB works fine on my T520, which also has an encrypted disk (if that is relevant).

Version-Release number of selected component (if applicable):
Fedora 22

How reproducible:
100%

Steps to Reproduce:
1. boot from USB
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 David Shea 2015-08-20 17:25:15 EDT
I would suggest looking more into ways to perform the memory test. Everything you're saying indicates that your computer is not booting, which means that either the media you are using to boot has gone bad, or something in your computer has.
Comment 2 Donald Berry 2015-08-20 17:54:26 EDT
David, I can still boot to the installed F22 system.  I just can't reinstall Fedora.

There are actually three problems:
1. reinstall does not work
2. Live CD does not work
3. Memtest does not work.

Note that a Ubuntu 15.04 USB boots fine on the same system.  I can also run the extended memory tests from the Lenovo diagnostics menu (F10), so it is not a hardware problem.

Don
Comment 3 Donald Berry 2015-08-21 11:13:35 EDT
- I also tried RHEL 7.1, it showed a similar blank screen with a cursor at the top left, then rebooted after a couple of seconds

- I tried the netinstall image with some of the kernel parameters in 'Common Kernel Problems - Crashes/Hangs'
(https://fedoraproject.org/wiki/Common_kernel_problems?rd=KernelCommonProblems#Crashes.2FHangs)

removed quiet
added vga=1 initcall_debug acpi=off nolapic noapic noapictimer earlyprintk=vga nosoftlockup edd=off

It still showed just a blank screen with a cursor

- I also tried the boot.text boot option, same result
Comment 4 Donald Berry 2015-08-21 15:09:35 EDT
I created a Fedora 22 VM on my current T520 laptop using the same netinstall ISO.  I used the same options (auto partitioning, full encryption).  I was then able to boot from the ISO after installing Fedora, so it seems to be a problem only with the W541.  Odd that the initial installation had no issues.

Can you suggest any diagnostics, tests, workarounds?
Comment 5 Donald Berry 2015-08-28 15:35:57 EDT
I recreated the USB using the disk utility in Fedora 22, and it worked.  Somehow writing the same ISO with dd on RHEL 6 did not.

Note You need to log in before you can comment on or make changes to this bug.