Bug 1255556 - state of bookmarks is not unset when the bookmark is removed
state of bookmarks is not unset when the bookmark is removed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gedit (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-20 19:47 EDT by Matěj Cepl
Modified: 2016-11-04 02:18 EDT (History)
2 users (show)

See Also:
Fixed In Version: gedit-3.14.3-15.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 02:18:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
suggested patch (1.32 KB, patch)
2016-01-24 12:38 EST, Matěj Cepl
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 753900 None None None Never

  None (edit)
Description Matěj Cepl 2015-08-20 19:47:28 EDT
1. Open a file in gedit with a bookmark (set via bookmarks plugin from the gedit-plugins).

2. Ctrl-B and Ctrl-Alt-B (jump to the bookmark and flip it off)

3. Change file and save

4. Reopen the file

Expected: no bookmark is present

Observed: the old bookmark is still at the place

When looking at the metadata with

    gvfs-info filename|grep metadata::gedit-bookmarks:

I can still see that the bookmark is saved in metadata::gedit
Comment 3 Matěj Cepl 2016-01-22 11:23:51 EST
This has been resolved (according to the upstream bug https://bugzilla.gnome.org/show_bug.cgi?id=753900 and my experience) in 3.14.4 which is a maintenance release.
Comment 4 Matěj Cepl 2016-01-24 12:38 EST
Created attachment 1117638 [details]
suggested patch
Comment 5 Matthias Clasen 2016-01-28 09:09:47 EST
thanks for the patch
Comment 9 errata-xmlrpc 2016-11-04 02:18:59 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2424.html

Note You need to log in before you can comment on or make changes to this bug.