Bug 125557 - Users can upload a file to a configuration channel and assign it a incorrect path
Summary: Users can upload a file to a configuration channel and assign it a incorrect ...
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
(Show other bugs)
Version: rhn340
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Robin Norwood
QA Contact: Fanny Augustin
URL: https://rhn.webqa.redhat.com/network/...
Whiteboard:
Keywords:
Depends On:
Blocks: 119090
TreeView+ depends on / blocked
 
Reported: 2004-06-08 18:23 UTC by Paul Dorsey
Modified: 2007-04-18 17:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-10 16:00:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Dorsey 2004-06-08 18:23:48 UTC
Description of problem:
Uploaded a file to a config channel and assigned it a bad path

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1.Uplaod a file to a config channel
2.Add a space to the Deploy File Path name
3.upload file
  
Actual results:
File is uploaded and the file path will have a space


Paul


Expected results:
Invalid path error?

Additional info:
Env webqa
User restwnudie
Pw dog8code

Comment 1 Robin Norwood 2004-06-10 16:00:36 UTC
Since when is a space invalid in a filename?

Pretty much anything goes for filenames in Unix...perhaps
unfortunately.  We should probably do more filtering than we are right
now, but that would be an RFE for another release.


Note You need to log in before you can comment on or make changes to this bug.