Bug 1255590 - Gluster: Variables in an error message are not replaced when it is shown on screen
Gluster: Variables in an error message are not replaced when it is shown on s...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
---
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-4.0.2
: 4.0.2
Assigned To: Sahina Bose
SATHEESARAN
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-21 00:21 EDT by Yuko Katabami
Modified: 2016-08-25 08:16 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-25 08:16:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Gluster
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.z+
rule-engine: planning_ack+
sabose: devel_ack+
sasundar: testing_ack+


Attachments (Terms of Use)
error message with variables (134.89 KB, image/png)
2015-08-21 00:21 EDT, Yuko Katabami
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 56965 master MERGED engine: Fix var substitution in error message 2016-07-12 05:59 EDT
oVirt gerrit 60127 master MERGED userportal: fix missing keys 2016-07-04 05:46 EDT
oVirt gerrit 60130 ovirt-engine-4.0 MERGED userportal: fix missing keys 2016-07-04 08:54 EDT

  None (edit)
Description Yuko Katabami 2015-08-21 00:21:25 EDT
Created attachment 1065435 [details]
error message with variables

Description of problem:
While translating/reviewing, we found the following message shown on the screen without having those variable replaced with the actual values:

Cannot ${action} ${type}. No up server found in ${clusterName}.

Version-Release number of selected component (if applicable): 3.6


How reproducible:


Steps to Reproduce:
1. Login to Web Admin Portal
2. Click Volumes tab and select a volume
3. Click Geo-Replication sub tab
4. Click Sync action button

Actual results:
Message is shown without having the variables replaced

Expected results:
Variables should be replaced with actual values

Additional info:
Screenshot attached
Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 07:02:51 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Sandro Bonazzola 2015-10-26 08:44:23 EDT
this is an automated message. oVirt 3.6.0 RC3 has been released and GA is targeted to next week, Nov 4th 2015.
Please review this bug and if not a blocker, please postpone to a later release.
All bugs not postponed on GA release will be automatically re-targeted to

- 3.6.1 if severity >= high
- 4.0 if severity < high
Comment 3 Red Hat Bugzilla Rules Engine 2015-12-10 21:23:41 EST
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 4 Sandro Bonazzola 2016-05-02 06:02:39 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 5 Yaniv Lavi 2016-05-23 09:17:54 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 6 Yaniv Lavi 2016-05-23 09:21:52 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 7 Sandro Bonazzola 2016-07-12 06:02:15 EDT
Moving back to post since this bug is targeted to 4.0.1 but referenced patches are not included in 4.0.1 branch. Please check this bug status and eventually re-target to 4.0.2
Comment 8 SATHEESARAN 2016-08-22 13:28:35 EDT
Tested with RHGS 3.1.3 ( vdsm-4.17.33-1.el7rhgs ) and RHV 4.0.2-7 by adding RHGS node to 3.6 cluster

1. Created a volume
2. Moved all the RHGS node in the cluster in to MAINTENANCE state
3. Select the volume, click on 'geo-replication' tab and select the operation as 'sync'

Observer the error dialog mentioning correct response - "Error while executing action: Cannot refresh Geo-replication session. No up server found in RHGS_Cluster_1."

Note You need to log in before you can comment on or make changes to this bug.