Bug 1255610 - W2K8R2 FC guest has no VGA driver on RHEV
W2K8R2 FC guest has no VGA driver on RHEV
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs (Show other bugs)
7.2
x86_64 Unspecified
medium Severity medium
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
V2V,P2V
:
Depends On: 1359086
Blocks: 1288337
  Show dependency treegraph
 
Reported: 2015-08-21 03:08 EDT by mxie@redhat.com
Modified: 2017-08-01 18:08 EDT (History)
6 users (show)

See Also:
Fixed In Version: libguestfs-1.36.1-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 18:08:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshots and log of conversion (355.58 KB, application/zip)
2015-08-21 03:08 EDT, mxie@redhat.com
no flags Details

  None (edit)
Description mxie@redhat.com 2015-08-21 03:08:05 EDT
Created attachment 1065454 [details]
screenshots and log of conversion

Description of problem:
W2K8R2 FC guest has no VGA driver on RHEV

Version-Release number of selected component (if applicable):
virt-v2v-1.28.1-1.49.el7.x86_64
virt-p2v-1.28.1-1.49.el7-1.iso


How reproducible:
100%

Steps to Reproduce:
 1.Install W2K8R2 on FC storage
 2.Boot into W2K8R2 FC host and check VGA driver of host is "Standard VGA driver", please refer to screenshot "W2K8R2 FC host has VGA driver.png"
 3.Boot the source machine into virt-p2v via PXE and input the ip and password of conversion server.
 4.Convert W2K8R2 FC host to RHEV via virt-p2v client
 5.After conversion,boot into W2K8R2 FC guest and check points on RHEV
 6.Find video controller of W2K8R2 FC guest has no VGA driver in device manager,please refer to screenshot "W2K8R2 FC guest has no VGA driver.png"
 7.If update the video controller manually, it will prompt "windows encountered a problem installing QXL driver", please refer to screenshot "Can't install qxl driver for VGA on W2K8R2-FC guest.png"

Actual results:
W2K8R2 FC guest's VGA driver could be updated to qxl on RHEV

Expected results:
W2K8R2 FC guest has no VGA driver on RHEV

Additional info:
W2K8R2 HPSA guest also has no VGA driver on RHEV
Comment 2 mxie@redhat.com 2015-08-21 05:52:35 EDT
Win7-x86-FC guest also has no VGA driver on RHEV, the original host has standard VGA driver
Comment 3 Richard W.M. Jones 2015-09-16 10:07:07 EDT
Moving to RHEL 7.3.
Comment 5 tingting zheng 2016-03-13 22:54:46 EDT
When convert win7 guests to rhev also hit this bug.
Comment 6 tingting zheng 2016-03-13 22:56:08 EDT
(In reply to tingting zheng from comment #5)
> When convert win7 guests to rhev also hit this bug.

Win 7 guest from xen server and use rhel7.2.z virt-v2v/libguestfs version.
Comment 7 Richard W.M. Jones 2017-02-16 10:31:50 EST
Fairly sure this should be fixed by the changes made upstream,
specifically in:
4c24531d907d888d20498bbac8bd4a4aef424e49

Please can we retest this with the rebased RHEL 7.4 package.
Comment 9 kuwei@redhat.com 2017-04-06 06:55:10 EDT
Verify the bug with below builds:
qemu-img-rhev-2.8.0-6.el7.x86_64
libvirt-3.2.0-1.el7.x86_64
libguestfs-1.36.3-1.el7.x86_64
virt-v2v-1.36.3-1.el7.x86_64
virt-p2v-1.36.3-1.el7.x86_64

Steps:
 1.Install windows2008r2 on FC storage
 2.Boot into windows2008r2 FC host and check VGA driver of host is "Standard VGA driver".
 3.Boot the source machine into virt-p2v via PXE and input the ip and password of conversion server.
 4.Convert windows2008r2 FC host to RHV via virt-p2v client
 5.After conversion,boot into windows2008r2 FC guest and check VGA driver of host is "Red Hat QXL GPU".

So,move the bug to VERIFIED
Comment 10 errata-xmlrpc 2017-08-01 18:08:55 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2023

Note You need to log in before you can comment on or make changes to this bug.