Bug 1255614 - "-balloon none" does not function as expected
"-balloon none" does not function as expected
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
7.2
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Luiz Capitulino
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-21 03:23 EDT by Shaolong Hu
Modified: 2015-09-25 10:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-25 10:44:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shaolong Hu 2015-08-21 03:23:40 EDT
Description of problem:
-------------------------
"-balloon none" does not function as expected


Version-Release number of selected component (if applicable):
---------------------------------------------
qemu-kvm-rhev-2.3.0-18.el7.x86_64


How reproducible:
----------------
100%


Steps to Reproduce:
--------------------
in our test case, "-balloon none" should forbid balloon device functioning with:

{"execute": "query-balloon"}
{"error": {"class": "DeviceNotActive", "desc": "No balloon device has been activated"}}


current behaviour is:

1. boot guest w/o balloon device, no matter w/ or w/o "-balloon none", will prompt:

{"execute": "query-balloon"}
{"error": {"class": "DeviceNotActive", "desc": "No balloon device has been activated"}}


2. boot guest w/ "-balloon none", no matter boot guest w/ a balloon device or hotplug a balloon device, won't prompt error:

{"execute": "query-balloon"}
{"return": {"actual": 1073741824}}




Expected results:
--------------------
As long as with "-balloon none", any balloon device should prompt:

{"execute": "query-balloon"}
{"error": {"class": "DeviceNotActive", "desc": "No balloon device has been activated"}}
Comment 3 Luiz Capitulino 2015-09-23 11:21:35 EDT
Could you please post the command-line you're using?

I can't reproduce it myself, but maybe there's something in your command-line that triggers the problem.
Comment 4 Shaolong Hu 2015-09-25 05:16:13 EDT
Hi, here is my cmd:

# /usr/libexec/qemu-kvm -enable-kvm -M pc -smp 4 -m 4G -name rhel6.3-64 -uuid 3f2ea5cd-3d29-48ff-aab2-23df1b6ae213 -drive file=/root/nfs/RHEL-Server-7.2-64-virtio.qcow2,cache=none,if=none,rerror=stop,werror=stop,id=drive-virtio-disk0,format=qcow2,aio=native -device virtio-blk-pci,drive=drive-virtio-disk0,id=device-virtio-disk0,bootindex=1 -netdev tap,script=/etc/qemu-ifup,id=netdev0 -device virtio-net-pci,netdev=netdev0,id=device-net0,mac=aa:54:00:11:22:33 -boot order=cd -monitor stdio -usb -device usb-tablet,id=input0 -chardev socket,id=s1,path=/tmp/s1,server,nowait -device isa-serial,chardev=s1 -monitor tcp::1234,server,nowait -vga qxl -global qxl-vga.revision=3 -spice port=5920,disable-ticketing -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -vnc :10 -qmp tcp:0:5555,server,nowait -balloon none -device virtio-balloon-pci,id=balloon1
QEMU 2.3.0 monitor - type 'help' for more information
(qemu) info balloon 
balloon: actual=4096
Comment 5 Luiz Capitulino 2015-09-25 10:44:22 EDT
So, you've got:

-balloon none -device virtio-balloon-pci,id=balloon1

Those options shouldn't be mixed together. The -balloon option is just a syntactic sugar for -device, where:

o -balloon none: does nothing
o -balloon virtio: creates a default balloon device just like -device

If all you want is to suppress the balloon device, just drop -balloon and the -device option creating it.

QEMU's syntactic sugar options cause problems more often than not. But as long as libvirt is not affected, it's not a concern for RHEL.

Note You need to log in before you can comment on or make changes to this bug.