Bug 125563 - Xorg -query $HOSTNAME restarts about every 2 min
Xorg -query $HOSTNAME restarts about every 2 min
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-08 15:03 EDT by Helmut Schlattl
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-08 06:57:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from /var/log/messages by enabling debug in gdm (8.58 KB, text/plain)
2004-06-14 13:43 EDT, Helmut Schlattl
no flags Details

  None (edit)
Description Helmut Schlattl 2004-06-08 15:03:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040428 Firefox/0.8

Description of problem:
Background:

When trying to log into my machine with gdm (only host in LAN) using
the standard gdm.conf file I always got "Gtk-Warning **: cannot open
display:   ". After a variety of trials (xhost+, DISPLAY-variable,
etc.), which were not successful, I could get around this problem by
changing in /etc/X11/gdm/gdm.conf below "[server-Standard]"

command=/usr/X11R6/bin/X -audit 0

to

command=/usr/X11R6/bin/X -audit 0 -query myhost

"myhost" being, of course, the hostname of my machine. 
(Interestingly, I can easily login via xdm or kdm without using the 
 default configurations.) 

Problem:
Since I updated from XFree86-4.3 to xorg-x11 I experienced serious
problems: I could login using gdm (with the above changes in the
gdm.conf), but after about 2 minutes I was thrown out and ended at the
gdm greeter again. I tracked it down to be a X-problem. When I
start from a text-console "X -query $HOSTNAME", I get an "X" on my
virtual terminal, but after about 2 minutes the X restarts with the
error message:

"XDM: too many retransmision, declaring session dead"

I thought it might be a firewall problem, so I disabled it (with
iptables -F), but the error still occured. 

"netstat -a" gave an additional line with
udp        0      0 *:32769                 *:* 

when "X -query ..." is running. The port number 32769 was not fixed
but changed everytime I manually killed X and started it again.


Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-3

How reproducible:
Always

Steps to Reproduce:
1.boot into runlevel 3 (or kill X, gdm, etc.)
2.X -query $HOSTNAME
3.
    

Actual Results:  X keeps restarting every 2 minutes or so

Additional info:
Comment 3 Mike A. Harris 2004-06-08 17:45:41 EDT
Please add the following to gdm.conf:

[debug]
Enable=true

This should give gobs of debug info.  Please redirect this info to
a file, or cut and paste to a file, and attach it as a bugzilla
file attachment.

TIA
Comment 4 Helmut Schlattl 2004-06-14 13:43:13 EDT
Created attachment 101119 [details]
Output from /var/log/messages by enabling debug in gdm

gdm has been started with the "-query" option in gdm.conf.
The attachment shows the debug-output from starting the gdm and 
from one restart after 90 seconds caused probably by a terminated X.
Comment 5 Mark McLoughlin 2004-06-14 14:01:34 EDT
You're trying to use XDMCP on localhost to work around some other
problem you were seeing. For a start change:

command=/usr/X11R6/bin/X -audit 0 -query myhost

back to

command=/usr/X11R6/bin/X -audit 0

and try and figure out your original problem.

This is your problem:

 > When trying to log into my machine with gdm (only host in LAN) 
 > using the standard gdm.conf file I always got "Gtk-Warning **: 
 > cannot open display:   "

Using XMCP (-query) is not the solution.

Try going back to factory-gdm.conf and if that doesn't help, please
give us the GDM logfile from that.
Comment 6 Helmut Schlattl 2004-06-15 14:13:43 EDT
O.K., I understand that it is not the usual way to start X -query
myhost, but I still don't understand, why Xorg has to restart then every
90 seconds (while XFree86 didn't). Is this an intended behaviour?
By the way, myhost is an alias to the LAN-IP address (192.168.0.10),
so not really localhost. 

Anyway, I found where the Gtk-Warning came from: in my 
/etc/profile.d/env.csh and env.sh I redefined some time ago
"DISPLAY=myhost:0.0" .
I don't remember why, but I probably had a reason then.

So with the standard DISPLAY variable and gdm.conf, I can log in using
gdm. I find it still puzzling, that with kdm and xdm, I did not have
any problems, even with the altered DISPLAY variable.
Comment 7 Søren Sandmann Pedersen 2004-07-08 06:57:33 EDT
What happens is that you start gdm without support for XDMCP
(enable=false in the [xdmcp] section of gdm.conf), then start an X
server with -query localhost. Since the gdm you started doesn't
support XDMCP, the X server doesn't get any response from gdm, and
after 90 seconds it gives up and resets or terminates of -once has
been specified.

However gdm still puts up a login box because you haven't told it it
shouldn't, so you can actually log in until the X server terminates
after 90 seconds. 


Note You need to log in before you can comment on or make changes to this bug.