This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1255661 - tigervnc server fails with -inetd option
tigervnc server fails with -inetd option
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Grulich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-21 05:31 EDT by Patrick Monnerat
Modified: 2015-11-16 18:20 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.5.0-2.fc23 tigervnc-1.5.0-2.fc22 tigervnc-1.5.0-2.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-07 12:36:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Monnerat 2015-08-21 05:31:30 EDT
Description of problem:
Option -inetd does not work anymore.

Version-Release number of selected component (if applicable):
1.5.0-1

How reproducible:
Always

Actual results:
Terminates immediately with message "Xvnc error: no free display number for -inetd".

Expected results:
A working session.

Additional info:
Please see https://github.com/TigerVNC/tigervnc/issues/183 and patch accordingly: this fixes the problem. Thanks in advance.
Comment 1 Fedora Update System 2015-08-21 22:51:31 EDT
tigervnc-1.5.0-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update tigervnc'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-13801
Comment 2 Fedora Update System 2015-08-22 00:19:24 EDT
tigervnc-1.5.0-2.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update tigervnc'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-13805
Comment 3 Fedora Update System 2015-08-22 12:25:43 EDT
tigervnc-1.5.0-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update tigervnc'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-13800
Comment 4 Patrick Monnerat 2015-08-24 04:47:24 EDT
1.5.0-2 works for me on rawhide. Thanks a lot :-)
Comment 5 Fedora Update System 2015-09-07 12:36:08 EDT
tigervnc-1.5.0-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2015-10-03 17:18:42 EDT
tigervnc-1.5.0-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2015-11-16 18:20:43 EST
tigervnc-1.5.0-2.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.