Bug 1255679 - LUKSError: luks device not configured - unable to reuse existing luks encrypted volume during GUI install
LUKSError: luks device not configured - unable to reuse existing luks encrypt...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.2
x86_64 Unspecified
high Severity high
: rc
: ---
Assigned To: Vratislav Podzimek
Release Test Team
abrt_hash:6eb59720dade3986da35e537958...
: Regression
Depends On:
Blocks: 1186677 1246125
  Show dependency treegraph
 
Reported: 2015-08-21 06:08 EDT by Ondrej Hudlicky
Modified: 2015-11-19 05:03 EST (History)
5 users (show)

See Also:
Fixed In Version: anaconda-21.48.22.42-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 05:03:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (673.59 KB, text/plain)
2015-08-21 06:08 EDT, Ondrej Hudlicky
no flags Details
File: anaconda.log (69.74 KB, text/plain)
2015-08-21 06:08 EDT, Ondrej Hudlicky
no flags Details
File: environ (492 bytes, text/plain)
2015-08-21 06:08 EDT, Ondrej Hudlicky
no flags Details
File: lsblk_output (1.57 KB, text/plain)
2015-08-21 06:08 EDT, Ondrej Hudlicky
no flags Details
File: nmcli_dev_list (1.82 KB, text/plain)
2015-08-21 06:08 EDT, Ondrej Hudlicky
no flags Details
File: os_info (507 bytes, text/plain)
2015-08-21 06:08 EDT, Ondrej Hudlicky
no flags Details
File: program.log (51.06 KB, text/plain)
2015-08-21 06:08 EDT, Ondrej Hudlicky
no flags Details
File: storage.log (207.18 KB, text/plain)
2015-08-21 06:08 EDT, Ondrej Hudlicky
no flags Details
File: syslog (96.83 KB, text/plain)
2015-08-21 06:08 EDT, Ondrej Hudlicky
no flags Details
File: ifcfg.log (1.27 KB, text/plain)
2015-08-21 06:08 EDT, Ondrej Hudlicky
no flags Details
File: packaging.log (186.80 KB, text/plain)
2015-08-21 06:08 EDT, Ondrej Hudlicky
no flags Details

  None (edit)
Description Ondrej Hudlicky 2015-08-21 06:08:11 EDT
Description of problem:
During install click on set root password

Version-Release number of selected component:
anaconda-21.48.22.35-1

The following was filed automatically by anaconda:
anaconda 21.48.22.35-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/formats/luks.py", line 193, in setup
    raise LUKSError("luks device not configured")
  File "/usr/lib/python2.7/site-packages/blivet/devices/storage.py", line 531, in setupParents
    _format.setup()
  File "/usr/lib/python2.7/site-packages/blivet/devices/storage.py", line 389, in _preSetup
    self.setupParents(orig=orig)
  File "/usr/lib/python2.7/site-packages/blivet/devices/storage.py", line 400, in setup
    if not self._preSetup(orig=orig):
  File "/usr/lib/python2.7/site-packages/blivet/devices/storage.py", line 523, in setupParents
    parent.setup(orig=orig)
  File "/usr/lib/python2.7/site-packages/blivet/devices/storage.py", line 389, in _preSetup
    self.setupParents(orig=orig)
  File "/usr/lib/python2.7/site-packages/blivet/devices/lvm.py", line 195, in _preSetup
    return StorageDevice._preSetup(self, orig=orig)
  File "/usr/lib/python2.7/site-packages/blivet/devices/storage.py", line 400, in setup
    if not self._preSetup(orig=orig):
  File "/usr/lib/python2.7/site-packages/blivet/devices/device.py", line 197, in setupParents
    parent.setup(orig=orig)
  File "/usr/lib/python2.7/site-packages/blivet/devices/lvm.py", line 651, in setupParents
    Device.setupParents(self, orig=orig)
  File "/usr/lib/python2.7/site-packages/blivet/devices/storage.py", line 389, in _preSetup
    self.setupParents(orig=orig)
  File "/usr/lib/python2.7/site-packages/blivet/devices/storage.py", line 400, in setup
    if not self._preSetup(orig=orig):
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 650, in execute
    self.device.setup(orig=True)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 377, in processActions
    action.execute(callbacks)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 373, in doIt
    self.devicetree.processActions(callbacks)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 223, in turnOnFilesystems
    storage.doIt(callbacks)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 186, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall, callbacks=callbacks_reg)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run
    threading.Thread.run(self, *args, **kwargs)
LUKSError: luks device not configured

Additional info:
addons:         org_fedora_oscap, com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=/distrotrees/70847/initrd method=http://download-01.eng.brq.redhat.com/pub/rhel/rel-eng/RHEL-7.2-20150820.0/compose/Workstation/x86_64/os/ repo=http://download-01.eng.brq.redhat.com/pub/rhel/rel-eng/RHEL-7.2-20150820.0/compose/Workstation/x86_64/os/  BOOT_IMAGE=/distrotrees/70847/kernel 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.10.0-306.0.1.el7.x86_64
product:        Red Hat Enterprise Linux 7
release:        Red Hat Enterprise Linux Server release 7.2 Beta (Maipo)
release_type:   pre-release
type:           anaconda
uid:            0
version:        7.2
Comment 1 Ondrej Hudlicky 2015-08-21 06:08:15 EDT
Created attachment 1065530 [details]
File: anaconda-tb
Comment 2 Ondrej Hudlicky 2015-08-21 06:08:17 EDT
Created attachment 1065531 [details]
File: anaconda.log
Comment 3 Ondrej Hudlicky 2015-08-21 06:08:19 EDT
Created attachment 1065532 [details]
File: environ
Comment 4 Ondrej Hudlicky 2015-08-21 06:08:20 EDT
Created attachment 1065533 [details]
File: lsblk_output
Comment 5 Ondrej Hudlicky 2015-08-21 06:08:21 EDT
Created attachment 1065534 [details]
File: nmcli_dev_list
Comment 6 Ondrej Hudlicky 2015-08-21 06:08:22 EDT
Created attachment 1065535 [details]
File: os_info
Comment 7 Ondrej Hudlicky 2015-08-21 06:08:24 EDT
Created attachment 1065536 [details]
File: program.log
Comment 8 Ondrej Hudlicky 2015-08-21 06:08:26 EDT
Created attachment 1065537 [details]
File: storage.log
Comment 9 Ondrej Hudlicky 2015-08-21 06:08:28 EDT
Created attachment 1065538 [details]
File: syslog
Comment 10 Ondrej Hudlicky 2015-08-21 06:08:29 EDT
Created attachment 1065539 [details]
File: ifcfg.log
Comment 11 Ondrej Hudlicky 2015-08-21 06:08:31 EDT
Created attachment 1065540 [details]
File: packaging.log
Comment 15 Jeff Bastian 2015-09-01 17:56:43 EDT
Another user experienced a similar problem:

I was trying to reuse an existing LVM-on-LUKS volume as the root filesystem volume.

I chose "I will configure partitioning" and hit Done
Expand the Unknown filesystems
Select the "Encrypted (LUKS)" partition and enter the password to unlock it
Expand the discovered operating sytsems and go to my "test" installation
Select the test /boot and set /boot as the mount point and click Update Settings
Do the same for /boot/efi
Select the test / and set / as the mount point, click the "Reformat" check-box,
  de-select the "Encrypt" check-box (since I don't want to do
  LUKS-on-LVM-on-LUKS), and click Update Settings
  NOTE: at this point, the Encrypt check-box is re-selected automatically and grayed out
Click Done
Click Accept Changes
Click Begin Installation
Anaconda crashes

addons:         com_redhat_kdump, org_fedora_oscap
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=RHEL-7.2\x20aarch64 ro vnc
hashmarkername: anaconda
kernel:         4.2.0-0.rc6.18.el7.aarch64
package:        anaconda-21.48.22.35-1
product:        Red Hat Enterprise Linux 7
reason:         LUKSError: luks device not configured
release:        Red Hat Enterprise Linux ComputeNode release 7.2 Beta (Maipo)
release_type:   pre-release
uid:            0
version:        7.2
Comment 17 Vratislav Podzimek 2015-09-03 07:42:49 EDT
Internal bug report that has been filed and resolved during the development of a minor release. No Doc Text required.
Comment 20 errata-xmlrpc 2015-11-19 05:03:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2284.html

Note You need to log in before you can comment on or make changes to this bug.