Bug 1255718 - Provisioning a RHEL5.9 host and then upgrade it to 5.11 creates a localhost.localdomain host record
Provisioning a RHEL5.9 host and then upgrade it to 5.11 creates a localhost.l...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-21 07:48 EDT by Fred van Zwieten
Modified: 2017-01-12 13:41 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-12 13:41:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fred van Zwieten 2015-08-21 07:48:10 EDT
Description of problem:
Scenario is as described in "Steps to Reproduce".

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Have a 5.9 kickstart repo, but not in a CV
2. Have 5Server in CV
3. Provision new host using 5.9 and Red Hat Default Kickstart

Actual results:
A correcly named hostrecord with no reports. Its yaml file has no classes.
A new Operating System "Red Hat 5.11" with a host count of 1. Clicking on this "1" gives a host record "localhost.localdomain" with reports. It's yaml file has classes.


Expected results:
one host record with repords and a correct yaml file

Additional info:
Deleting the localhost.localdomain maps everything back to the correct host record.

We created a workaround by moving the "yum update" in the Red Hat Default Kickstart after all puppet related stuff, yust before the end. We did this because the initial puppet run creates the host record and if the yum update has not been done it will still use the 5.9 OS.
Comment 2 Bryan Kearney 2016-07-08 16:23:01 EDT
Per 6.3 planning, moving out non acked bugs to the backlog
Comment 4 Bryan Kearney 2017-01-12 13:41:53 EST
This is an older bug which I do not envision being addressed in the near term. I am closing this out. If you believe doing so is an issue, please feel free to re-open and provide additional business information. Thank you.

Note You need to log in before you can comment on or make changes to this bug.