Bug 1255721 - RHEL 5 OS objects are named differently as RHEL6 and 7
RHEL 5 OS objects are named differently as RHEL6 and 7
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-21 07:52 EDT by Fred van Zwieten
Modified: 2017-01-12 10:13 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-12 10:13:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Scrrenshot of issue (55.79 KB, image/png)
2015-08-21 07:52 EDT, Fred van Zwieten
no flags Details

  None (edit)
Description Fred van Zwieten 2015-08-21 07:52:00 EDT
Created attachment 1065559 [details]
Scrrenshot of issue

Description of problem:
OS objects created from the syncing of a kickstart repo have a different format as OS objects created as a result from a client doing a yum update to a different minor version.

Version-Release number of selected component (if applicable):


How reproducible:
See description

Steps to Reproduce:
1.
2.
3.

Actual results:
See screenshot

Expected results:
consistent naming

Additional info:
Comment 1 Fred van Zwieten 2015-08-21 07:54:18 EDT
Actually, this is a different format for RHEL5 then for RHEL6 and 7.
Comment 2 Brad Buckingham 2015-11-19 09:57:00 EST
Hi Fred,

I ran a test with Satellite 6.1.4 and I am not seeing the behavior described; therefore, wondering if perhaps it was either resolved during z-stream or if my test scenario may be different.

Scenario (all from UI):

- Content-> Red Hat Subscriptions : import a manifest
- Content -> Red Hat Repositories : enable Kickstart repos for Red Hat Enterprise Linux Server 5.9, 6.7 & 7.1
- Content -> Sync Status : select all 3 repos and initiate a sync
- Once the sync is finished : view the created Operating Systems at 'Hosts -> Operating systems'
- observe that the following were created:
  - RedHat 5.9
  - RedHat 6.7
  - RedHat 7.1

Is this similar to what you performed?
If not, can you highlight what may be different?

Also, would it be possible for you to try a test on the lastest (Satellite 6.1.4)?

Thanks!
Comment 3 Fred van Zwieten 2015-11-19 10:57:51 EST
I am no longer on this site and I also was not there when they did this, so I am not entirely sure how they managed to do this. I just observed this when I visited. They were using a disconnected sat6 then (has been reinstalled as a connected since). So, it might be the issue is with the content iso's
Comment 4 Bryan Kearney 2016-07-26 15:11:26 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 5 Bryan Kearney 2017-01-12 10:13:01 EST
This is an older bug which I do not envision being fixed in the near term. I am closing this out. If you believe doing so is an issue, please feel free to re-open and provide additional business information. Thank you.

Note You need to log in before you can comment on or make changes to this bug.