This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1255769 - Reports server doesn't detect Data Center
Reports server doesn't detect Data Center
Status: CLOSED WORKSFORME
Product: oVirt
Classification: Community
Component: ovirt-engine-reports (Show other bugs)
3.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Shirly Radco
Pavel Stehlik
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-21 09:52 EDT by Karolína Hajná
Modified: 2016-05-19 21:23 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-25 04:45:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karolína Hajná 2015-08-21 09:52:41 EDT
Description of problem:
Data Centers added in engine are not detected if ovirt-engine is installed and set up alone first and dwh + reports are installed and set up afterwards. In case all three components are installed and set up together, data centers are detected correctly.

Version-Release number of selected component (if applicable):
3.6.0-0.0.master.20150804111407.git122a3a0.el6

How reproducible:
100%

Steps to Reproduce:
1. Install ovit-engine and use engine-setup
2. Install ovirt-engine-dwh and ovirt-engine-reports and use engine-setup again
3. Go to reports portal and open some report where you can choose data center in IC (for example BR48, BR7, ...)

Actual results:
There's no data center available.

Expected results:
You should be able to choose Default data center (and all others you added) in the IC.
Comment 1 Yaniv Lavi (Dary) 2015-08-25 03:55:46 EDT
Did you add hosts to the engine? 
The DWH only collects data on dcs that are not uninitialized.
Comment 2 Karolína Hajná 2015-08-25 04:45:27 EDT
After adding a host to one of my engines which I used to reproduce the issue, the report shows data center correctly now. Closing this bug since I can't reproduce it.

Note You need to log in before you can comment on or make changes to this bug.