Bug 125578 - missing keyboard layout
missing keyboard layout
Status: CLOSED DUPLICATE of bug 120858
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2004-06-08 19:58 EDT by Jose David Forero
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:04:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Using an English keyboard with accents in Fedora Core 2 and KDE (1.22 KB, text/plain)
2004-06-09 12:08 EDT, Jose David Forero
no flags Details

  None (edit)
Description Jose David Forero 2004-06-08 19:58:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
After the upgrade of my Fedora from Core 1 to Core 2, I noticed very
serious problem - my keyboard layouts were missing, no switching -
nothing! In KDE Control Panel -> Regional & Accessibility -> Keyboard
Layout, the Available Layouts list was empty, also XKB options list
was empty too.
I was astonished! After a long Google struggle, I found the solution
here. It seems that the XFree86 to XOrg migration, which occurs in
Core 2, has caused this problem. Seems also that Control Center
expects to find the available layouts in the xfree86.lst file, while
the new xorg layouts are placed in xorg.lst.
Execution of these commands as root fixed my problem:

cd /usr/X11R6/lib/X11/xkb/rules
ln -s xorg.lst xfree86.lst
ln -s xorg.xml xfree86.xml

Thanks to Ralf Ertzinger for his post - it saved my day!

The URI to TrackBack this entry is:


      This did not work here, so here�s what did work:

      cd /usr/X11R6/lib/X11/xkb/rules
      ln -s xorg-it.lst xfree86-it.lst
      ln -s xorg.lst xfree86.lst
      ln -s xorg.xml xfree86.xml

      Comment by Doncho N. Gunchev � 6/6/2004 @ 3:55 am

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Enter the KDE desktop
2. Open the Control Center
3. Regional & accessibility / Keyboard layout

Actual Results:  I can not compose spanish characters with my english

Expected Results:  Please I want to work like in Fedora Core 1 or
RedHat 6/7/8/9. Thanks.

Additional info:

Comment 1 Mike A. Harris 2004-06-08 20:25:40 EDT

*** This bug has been marked as a duplicate of 120858 ***
Comment 2 Jose David Forero 2004-06-09 12:08:31 EDT
Created attachment 100992 [details]
Using an English keyboard with accents in Fedora Core 2 and KDE

I am already working with US keyboard and spanish accents in Fedora 2/KDE with
this guide.
Comment 3 Red Hat Bugzilla 2006-02-21 14:04:00 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.