Bug 1255823 - manpages missing from rhel-tools image
manpages missing from rhel-tools image
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rhel-tools-docker (Show other bugs)
7.1
All Linux
high Severity high
: rc
: 7.1
Assigned To: Eliska Slobodova
Martin Jenner
Vikram Goyal
: Regression
Depends On:
Blocks: 1186913 1252566
  Show dependency treegraph
 
Reported: 2015-08-21 12:03 EDT by James W. Mills
Modified: 2015-09-15 11:45 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-15 11:45:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James W. Mills 2015-08-21 12:03:38 EDT
Description of problem:

Latest rhel7/rhel-tools container image has no manpages installed


Version-Release number of selected component (if applicable):

registry.access.redhat.com/rhel7/rhel-tools                      latest              37b5171f5352        2 weeks ago         990.4 MB

How reproducible:

100%

Steps to Reproduce:
man <anything>

Actual results:

No manual entry for <anything>

Expected results:

manpage for <anything>

Additional info:

THis is a regression
Comment 6 Yoana Ruseva 2015-08-31 07:58:45 EDT
Hi, 

The article about rhel-tools mentions that it contains man pages: 

https://access.redhat.com/articles/1336853 (in the Overview section)

I am not sure if the respective articles about rsyslog and sadc should mention that they do NOT contain man pages, since this is expected behaviour.

Additionally, there are two other places where a note can go:

1) the Release Notes, under "Other Notes", explaining that no man pages is the expected behaviour, unless there is a workaround as in the case of rhel-tools

2) the "Running Super Privileged Containers..." article: https://access.redhat.com/articles/1342703

I think both should be updated.
Comment 7 Yoana Ruseva 2015-08-31 08:52:14 EDT
Ok, after consulting Eliska, I learned it's about the base images, and in this case the most appropriate places are the Release Notes and the "Recommended Practices for Container Development" article: https://access.redhat.com/articles/1483053.
Comment 13 errata-xmlrpc 2015-09-15 11:45:25 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1802.html

Note You need to log in before you can comment on or make changes to this bug.