Bug 1255850 - CLI db2index fails with usage errors
CLI db2index fails with usage errors
Status: CLOSED DUPLICATE of bug 1255851
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Noriko Hosoi
Viktor Ashirov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-21 13:01 EDT by Noriko Hosoi
Modified: 2015-08-22 12:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-22 12:00:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noriko Hosoi 2015-08-21 13:01:25 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/389/ticket/48254

For instance, if db2index is run against the standard browsing index, it fails.
{{{
sh -x /usr/sbin/db2index -Z SERVERID -n userRoot -T "by MCC ou=People dc=example dc=com"

+ /usr/sbin/ns-slapd db2index -D /etc/dirsrv/slapd-SERVERID -n userRoot= -T by MCC ou=People dc=example dc=com
usage: ns-slapd db2index -D configdir -n backend-instance-name [-d debuglevel] {-t attributetype}* {-T VLV Search Name}*
}}}


There are 2 issues.
{{{
1. '=' is accidentally added to "userRoot"
2. "by MCC ou=People dc=example dc=com" is not passed as one string, but as separate words.
}}}
Comment 2 Viktor Ashirov 2015-08-22 12:00:35 EDT

*** This bug has been marked as a duplicate of bug 1255851 ***

Note You need to log in before you can comment on or make changes to this bug.