Bug 1255895 - [extmgr] load extension properties as unicode
[extmgr] load extension properties as unicode
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Extension-API (Show other bugs)
3.5.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ovirt-3.5.5
: 3.5.5
Assigned To: Alon Bar-Lev
Ondra Machacek
infra
: CodeChange
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-21 15:50 EDT by Alon Bar-Lev
Modified: 2016-02-10 14:09 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-26 09:43:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
alonbl: ovirt‑3.5.z?
alonbl: ovirt‑3.6.0?
rule-engine: planning_ack?
alonbl: devel_ack+
rule-engine: testing_ack?


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45195 master MERGED extmgr: read properties files as unicode Never
oVirt gerrit 45197 ovirt-engine-3.6 MERGED extmgr: read properties files as unicode Never
oVirt gerrit 45198 ovirt-engine-3.5 MERGED extmgr: read properties files as unicode Never

  None (edit)
Description Alon Bar-Lev 2015-08-21 15:50:48 EDT
Currently the properties files are read as ANSI, dropping any unicode char.
Comment 1 Pavel Novotny 2015-09-17 09:22:25 EDT
Please can you describe what this bug is about and how to verify it? Thanks.
Comment 2 Alon Bar-Lev 2015-09-17 10:02:59 EDT
(In reply to Pavel Novotny from comment #1)
> Please can you describe what this bug is about and how to verify it? Thanks.

for example create ldap configuration with unicode profile name, you can copy/paste from here between arrows:

-->פרופיל1<--

you will notice that before we could not read this properties file.
Comment 3 Ondra Machacek 2015-09-18 07:51:27 EDT
I just can't get it work.

When I try to login as user with UTF-8 chars. I get no 'search for princ', bind is successfull:

2015-09-18 13:37:18,416 DEBUG [org.ovirt.engineextensions.aaa.ldap.Framework] (ajp-/127.0.0.1:8702-6) BindRequest: SimpleBindRequest(dn='čeněk@ad-w2k12r2.rhev.lab.eng.brq.redhat.com')
2015-09-18 13:37:18,416 DEBUG [org.ovirt.engineextensions.aaa.ldap.Framework] (ajp-/127.0.0.1:8702-6) bind
2015-09-18 13:37:18,419 DEBUG [org.ovirt.engineextensions.aaa.ldap.Framework] (ajp-/127.0.0.1:8702-6) BindResult: LDAPResult(resultCode=0 (success), messageID=3)
........
2015-09-18 13:37:18,459 DEBUG [org.ovirt.engineextensions.aaa.ldap.Framework] (ajp-/127.0.0.1:8702-6) SearchRequest: SearchRequest(baseDN='', scope=SUB, deref=NEVER, sizeLimit=0, timeLimit=0, filter='&(userPrincipalName=čeněk@ad-w2k12r2.rhev.lab.eng.brq.redhat.com)', attrs={cn}, controls={SimplePagedResultsControl(pageSize=100, isCritical=false)})
2015-09-18 13:37:18,462 DEBUG [org.ovirt.engineextensions.aaa.ldap.Framework] (ajp-/127.0.0.1:8702-6) SearchResult: SearchResult(resultCode=0 (success), messageID=3, entriesReturned=0, referencesReturned=0, responseControls={SimplePagedResultsControl(pageSize=0, isCritical=false)})



When I try to use UTF-8 user in config file, fails while creating gc pool:

2015-09-18 13:48:03,369 DEBUG [org.ovirt.engineextensions.aaa.ldap.Framework] (ServerService Thread Pool -- 54) BindRequest: SimpleBindRequest(dn='čeněk@ad-w2k12r2.rhev.lab.eng.brq.redhat.com')
2015-09-18 13:48:03,369 DEBUG [org.ovirt.engineextensions.aaa.ldap.Framework] (ServerService Thread Pool -- 54) Creating LDAPConnectionPool
..
2015-09-18 13:48:03,728 DEBUG [org.ovirt.engineextensions.aaa.ldap.Framework] (ServerService Thread Pool -- 54) Sequence ad-open-pools create gc pool failed due to exception: 80090308: LdapErr: DSID-0C0903C5, comment: AcceptSecurityContext error, data 52e, v2580
2015-09-18 13:48:03,729 DEBUG [org.ovirt.engineextensions.aaa.ldap.Framework] (ServerService Thread Pool -- 54) Exception during sequence: LDAPException(resultCode=49 (invalid credentials), errorMessage='80090308: LdapErr: DSID-0C0903C5, comment: AcceptSecurityContext error, data 52e, v2580', diagnosticMessage='80090308: LdapErr: DSID-0C0903C5, comment: AcceptSecurityContext error, data 52e, v2580')


Bind and search works OK in ldapsearch. Is issue on my side?
Comment 4 Alon Bar-Lev 2015-09-18 08:00:39 EDT
> When I try to use UTF-8 user in config file, fails while creating gc pool:

the issue here is plain text, such as profile name (user visible) or any unicode string, unrelated to aaa specifically, the read of the file was invalid.

never actually tried bind user this way... but I do know that utf-8 user is working in master with sso (first time we actually tried that).

let's resolve this bug if profile name can be utf-8 other issues will be addressed when sso will be available.

but I will try this anyway :)
Comment 5 Ondra Machacek 2015-09-18 08:08:55 EDT
profile name works fine with utf-8
Comment 6 Red Hat Bugzilla Rules Engine 2015-10-18 04:21:35 EDT
Fixed bug tickets must have version flags set prior to fixing them. Please set the correct version flags and move the bugs back to the previous status after this is corrected.
Comment 7 Sandro Bonazzola 2015-10-26 09:43:41 EDT
oVirt 3.5.5 has been released including fixes for this issue.

Note You need to log in before you can comment on or make changes to this bug.