This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1255945 - Missing / home from list of mandatory Directories
Missing / home from list of mandatory Directories
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: install-guide (Show other bugs)
devel
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Bokoc
Fedora Docs QA
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-22 02:42 EDT by Leslie Satenstein
Modified: 2016-01-21 09:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-21 09:06:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leslie Satenstein 2015-08-22 02:42:23 EDT
Description of problem:

http://docs.fedoraproject.org/en-US/Fedora/22/html/Installation_Guide/sect-disk-partitions-how-many.html




B.3.3. How Many Partitions?
....

Unless you have a reason for doing otherwise, you should at least create the following partitions: swap, /boot/, and / (root).
See Section 5.4.10.6, “Recommended Partitioning Scheme” for more information about the recommended partitioning scheme. 
Version-Release number of selected component (if applicable):

 

Expected results:

It is not /boot/ but /boot  and omitted was /home 

If /home is not specified, it will be created within /.

No mention was made about /var and /opt

or a user partition /mypartition        (for example)
Comment 1 Pete Travis 2015-08-28 18:57:34 EDT
Following the link at the bottom of the section you cited will lead you to https://docs.fedoraproject.org/en-US/Fedora/22/html/Installation_Guide/sect-installation-gui-manual-partitioning-recommended.html - the detailed recommendation.  Omissions are deliberate.
Comment 2 Leslie Satenstein 2015-08-30 00:47:37 EDT
Hi Pete.

Actually only /boot,  and / are mandatory.

If /home is omitted, it will/may be included within / with some unspecified default size. This option is taken if automatic repartition of space is chosen and the partition method is standard.


If swap is omitted, two options have been seen to occur.

No assignment for swap is placed within fstab. 
if with btrfs as the file system space for swap is allocated, but not assigned and it does not appear within fstab

or 

no swap partition at all is created.

Worse

with / and /home being adjacent,  anaconda merges the two to a single partition.

There is no documentation regarding rules when btrfs is chosen in lieu of lvm.

Test it yourself to validate my points.

Moreover
If /opt and /var are chosen as well, these are recognized by anaconda and the space will be readjusted to accomodate these two extra directories.


What is not well documented are the options  automatic/standard, lvm, btrfs xfs, etc. The documentation should include a matrix to explain the decisions taken for the lvm, btrfs, and manual configurations.

Missing is what one does when more than one disk is chosen along with the various options.

For example,   if I specify no swap on the single disk that is where Fedora 22 will be assigned, but I include a swap from a second disk, depending on automatic/manual configuration options, I may get two swap files instead of one.

What are the rules?
Comment 3 Petr Bokoc 2015-10-19 16:26:46 EDT
I changed the wording in the section to indicate that only / and /boot are required; neither swap nor /home are *technically* necessary. I also added a mention of /boot/efi, biosboot and PRePBoot, since one of those might be necessary for a successful installation too, depending on the hardware.

It's not necessary to mention swap in this section, since it's recommended (and described as such in the Recommended Partitioning Scheme section) but not mandatory; same goes for /var, /opt, /usr and anything else - if someone insists on making those separate, they probably know what they're doing so they don't need it explained. LVM/Btrfs doesn't need to be mentioned either, this appendix is about *standard partitions*.

You can see the changes I made in https://da.gd/FTF5 .

Note You need to log in before you can comment on or make changes to this bug.