Bug 1255947 - add little endian powerpc targets
add little endian powerpc targets
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cross-binutils (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Howells
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1255946
  Show dependency treegraph
 
Reported: 2015-08-22 03:13 EDT by Dan Horák
Modified: 2015-12-19 13:26 EST (History)
4 users (show)

See Also:
Fixed In Version: cross-binutils-2.25.1-2.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-19 13:26:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Horák 2015-08-22 03:13:26 EDT
Per discussion on #fedora-ppc it seems the current cross-{binutils,gcc} lack the little endian powerpc targets, please add them.

<benh> hey
<benh> somebody knows if the ppc64 cross compile in x86 fedora can do LE ?
<benh> powerpc64-linux-gnu-ld: unrecognised emulation mode: elf64lppc
<benh> Supported emulations: elf64ppc elf32ppc elf32ppclinux elf32ppcsim
<sharkcz> benh: hi, yes, the cross binutils/gcc spec files have no mention about LE as target, can you please open a bug to add it?
<benh> sharkcz: it works if I just use -m elf64ppc and -EL
<benh> sharkcz: so not sure it's actually a problem, but it's certainly a difference vs. what's in ubuntu
<sharkcz> the native LE ld lists ld: supported emulations: elf64lppc elf32lppc elf32lppclinux elf32lppcsim elf32_spu elf32ppclinux elf32ppc elf32ppcsim elf64ppc - so I think we should add LE as a target to the cross-tools too
<sharkcz> does it understand ELFv2 in the current state?
<benh> sharkcz: it seems to, my stuff works once built
<benh> sharkcz: but yeah it looks like it should still probably be fixed
Comment 1 David Howells 2015-08-24 10:20:42 EDT
Patch 14 in the main binutils package is applied only if a ppc64le package is being built.  But since its effects are only felt if the LD_FORCE_LE envvar is set, that shouldn't be a problem - but it *will* also affect non-ppc64le arches if that is set.

Other than that, there doesn't seem to be anything that would prevent me from creating a ppc64le-capable binutils.  cross-gcc is another matter, but I'll deal with that in bug 1255946.
Comment 2 David Howells 2015-08-24 10:39:31 EDT
(In reply to David Howells from comment #1)
> Other than that, there doesn't seem to be anything that would prevent me
> from creating a ppc64le-capable binutils.  cross-gcc is another matter, but
> I'll deal with that in bug 1255946.

Actually, there's nothing else, not even in gcc.  I'm confusing this with another binutils cross-compiler for RHEL.
Comment 3 David Howells 2015-08-24 11:18:33 EDT
Do we have a preference for making one powerpc binutils/gcc that does both, or separate BE and LE ones?
Comment 4 Fedora Update System 2015-08-25 09:32:01 EDT
cross-binutils-2.25.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14239
Comment 5 Fedora Update System 2015-08-26 00:25:08 EDT
cross-binutils-2.25.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update cross-binutils'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14239
Comment 6 Fedora Update System 2015-12-10 09:22:59 EST
cross-binutils-2.25.1-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-bf5de08226
Comment 7 Fedora Update System 2015-12-11 01:01:17 EST
cross-binutils-2.25.1-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update cross-binutils'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-bf5de08226
Comment 8 Fedora Update System 2015-12-19 13:26:36 EST
cross-binutils-2.25.1-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.