Bug 1255961 - SELinux is preventing rawtobr3 from 'execute' accesses on the file /etc/ld.so.cache.
SELinux is preventing rawtobr3 from 'execute' accesses on the file /etc/ld.so...
Status: CLOSED DUPLICATE of bug 1255960
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:56df93653fae5d003c937efc76f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-22 08:19 EDT by ambrish dhaka
Modified: 2015-08-27 12:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-27 12:58:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ambrish dhaka 2015-08-22 08:19:17 EDT
Description of problem:
SELinux is preventing rawtobr3 from 'execute' accesses on the file /etc/ld.so.cache.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that rawtobr3 should be allowed execute access on the ld.so.cache file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep rawtobr3 /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:cupsd_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:ld_so_cache_t:s0
Target Objects                /etc/ld.so.cache [ file ]
Source                        rawtobr3
Source Path                   rawtobr3
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           glibc-2.21-7.fc22.x86_64 glibc-2.21-7.fc22.i686
Policy RPM                    selinux-policy-3.13.1-128.10.fc22.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.1.5-200.fc22.x86_64 #1 SMP Mon
                              Aug 10 23:38:23 UTC 2015 x86_64 x86_64
Alert Count                   1
First Seen                    2015-08-22 17:47:35 IST
Last Seen                     2015-08-22 17:47:35 IST
Local ID                      2148072e-db4c-499b-96b4-586a5a8fd4c9

Raw Audit Messages
type=AVC msg=audit(1440245855.231:656): avc:  denied  { execute } for  pid=3618 comm="rawtobr3" path="/etc/ld.so.cache" dev="dm-1" ino=397760 scontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:ld_so_cache_t:s0 tclass=file permissive=0


Hash: rawtobr3,cupsd_t,ld_so_cache_t,file,execute

Version-Release number of selected component:
selinux-policy-3.13.1-128.10.fc22.noarch

Additional info:
reporter:       libreport-2.6.2
hashmarkername: setroubleshoot
kernel:         4.1.5-200.fc22.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2015-08-27 12:58:01 EDT

*** This bug has been marked as a duplicate of bug 1255960 ***

Note You need to log in before you can comment on or make changes to this bug.