Bug 1256036 - [VDSM] monitor domain complains it can't find fcp domains on hsm hosts
[VDSM] monitor domain complains it can't find fcp domains on hsm hosts
Status: CLOSED DUPLICATE of bug 1101009
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity medium
: ovirt-3.6.0-rc3
: 3.6.0
Assigned To: Fred Rolland
Aharon Canan
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-23 10:23 EDT by Ori Gofen
Modified: 2016-05-25 21:49 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-14 03:37:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (2.85 MB, application/x-gzip)
2015-08-25 04:10 EDT, Ori Gofen
no flags Details

  None (edit)
Description Ori Gofen 2015-08-23 10:23:47 EDT
Description of problem:
When having an fcp storage domain on a datacenter with more than one host, the hsm hypervisors will wrongly complain they can't "see" the fcp storage domain every 320 seconds.
from vdsm.log:

Thread-1171::ERROR::2015-08-23 16:51:06,447::sdc::138::Storage.StorageDomainCache::(_findDomain) looking for unfetched domain 5f081e07-1e99-4012-9fd9-345f8d74a116
Thread-1171::ERROR::2015-08-23 16:51:06,447::sdc::155::Storage.StorageDomainCache::(_findUnfetchedDomain) looking for domain 5f081e07-1e99-4012-9fd9-345f8d74a116

Where 5f081e07-1e99-4012-9fd9-345f8d74a116 is an fcp domain

Version-Release number of selected component (if applicable):
vdsm-4.17.2-1.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1.create an fcp domain

Actual results:
HSM hypervisors complain they can't reach the fcp domain

Expected results:
The Error should be thrown only if the hypervisor can't see the storage

Additional info:
Comment 1 Allon Mureinik 2015-08-24 06:20:12 EDT
Logs please?
Comment 2 Ori Gofen 2015-08-25 04:10:31 EDT
Created attachment 1066772 [details]
logs

Hey, sorry about it :)
Comment 3 Fred Rolland 2015-10-13 09:16:39 EDT
Every time the monitoring task wakes up, it will check when was the last time the domain have been refreshed to pick up changes on it.
If it has been 300 sec or more , the domain will be dropped from the cache and will be refreshed.
There is a configuration value 'repo_stats_cache_refresh_timeout' in config.py that define the refresh time (300 sec by default).

The log you mentioned is from StorageDomainCache when it failed to find the domain in the cache and start refreshing it.

This log does not mean the hypervisor is not seeing the storage, but that it did not find it in its cache and will refresh it.

In my opinion, there is nothing to fix here.
Comment 4 Allon Mureinik 2015-10-14 03:37:14 EDT

*** This bug has been marked as a duplicate of bug 1101009 ***

Note You need to log in before you can comment on or make changes to this bug.