Bug 1256045 - Libinput regularly interprets two-finger scrolling as right-mouse click
Libinput regularly interprets two-finger scrolling as right-mouse click
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: libinput (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-23 11:55 EDT by Richard Geary
Modified: 2015-09-21 06:47 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.0.1-3.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-21 06:47:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Scroll up and down. Play in a chrome window (42.71 KB, text/plain)
2015-08-23 11:55 EDT, Richard Geary
no flags Details
Another accidental right-click example (148.21 KB, text/plain)
2015-08-25 00:18 EDT, Richard Geary
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 91818 None None None Never

  None (edit)
Description Richard Geary 2015-08-23 11:55:53 EDT
Created attachment 1066060 [details]
Scroll up and down. Play in a chrome window

Description of problem:
Attempting to use the two-finger scroll will regularly be interpreted as a right-mouse click instead.  Using Elan touchpad.

Version-Release number of selected component (if applicable):
libinput-0.99.1-1.fc22

How reproducible:
Regularly, randomly

Steps to Reproduce:
1. Scroll up
2. Scroll down
3. Right-mouse button menu will appear

Actual results:
Right mouse button menu appears

Expected results:
Scrolling

Additional info:
See attached. I do a two-finger movement up then down. The up movement scrolls, the down registers a right-click.  Play in a chrome window.
Comment 1 Peter Hutterer 2015-08-23 20:07:50 EDT
confirmed but not sure how to fix this. In your evemu recording at 0.747156 seconds both fingers are released, that's the switch to scrolling down.

first finger down is at 1.117911, at 1.136581 the second finger is set down again. but, and this is the issue: at 1.179478 the second finger is released and there was no significant movement since the down event (~0.2mm for the second finger). Hence libinput interprets this as two-finger tap. The finger is set down again at 1.227328 and continues to move normally, that's the series of scroll events then.

so judging by the event sequence, libinput does the right thing. we need to figure out why the touchpad loses track of the finger. do you notice any other influencing factors here? distance between fingers, speed of motion, etc?
Comment 2 Richard Geary 2015-08-25 00:18:45 EDT
Created attachment 1066729 [details]
Another accidental right-click example

The events where it erroneously detects a right-click occur when I'm intending to scroll only a small number of lines.  The right click menu appears faster than the two-finger scroll reacts, though that may be because two-finger scroll just feels laggy on libinput.
Comment 3 Peter Hutterer 2015-08-30 19:53:10 EDT
ok, this one appears to be a bug in libinput. The order of events here is:

finger 1 down
finger 2 down
finger 1 up
<finger 2 is held down>

imo this order should not trigger a right-button tap and arguably no tap event at all.
Comment 4 Peter Hutterer 2015-08-30 21:31:34 EDT
give this one a try please:
http://koji.fedoraproject.org/koji/taskinfo?taskID=10891768
Comment 5 Richard Geary 2015-08-30 23:01:19 EDT
How do I install this?  Is this in libinput 1.0.0-1.fc22 in updates-testing?
I've installed 1.0.0-1.fc22 and I can get it to occur, but its for very slight movements.

On Windows, if the movement is ambiguous it does both - it brings up the right click menu & scrolls
Comment 6 Peter Hutterer 2015-08-31 00:29:56 EDT
on the bottom, click on the link with your arch description (likely x86_64), then at the next page you'll see a bunch of links to rpm files. download the libinput rpm and install it with sudo dnf install /path/to/rpm and after restarting X it takes effect.

if you have the current -devel or -debuginfo packages installed, you'll either have to remove them first or download the updates for those too.
Comment 7 Richard Geary 2015-09-03 21:44:51 EDT
This seems fixed, thanks!
Comment 8 Fedora Update System 2015-09-06 21:16:53 EDT
libinput-1.0.1-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15235
Comment 9 Fedora Update System 2015-09-06 21:29:28 EDT
libinput-1.0.1-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15236
Comment 10 Fedora Update System 2015-09-07 14:19:36 EDT
libinput-1.0.1-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update libinput'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15236
Comment 11 Fedora Update System 2015-09-07 14:20:55 EDT
libinput-1.0.1-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update libinput'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15235
Comment 12 Fedora Update System 2015-09-15 15:50:23 EDT
libinput-1.0.1-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2015-09-18 16:45:36 EDT
libinput-1.0.1-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16191
Comment 14 Fedora Update System 2015-09-20 10:58:01 EDT
libinput-1.0.1-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update libinput'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16191
Comment 15 Fedora Update System 2015-09-21 06:47:17 EDT
libinput-1.0.1-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.