Bug 1256050 - abrt-hook-ccpp: Failed to create core_backtrace: waitpid failed: Permission denied
abrt-hook-ccpp: Failed to create core_backtrace: waitpid failed: Permission d...
Status: CLOSED DUPLICATE of bug 1245477
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
22
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-23 12:36 EDT by Milan Bouchet-Valat
Modified: 2015-08-24 09:49 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-24 09:49:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Bouchet-Valat 2015-08-23 12:36:14 EDT
I'm experiencing a strange bug in which my GNOME session is closed without any reason, but I can't identify the process which is crashing. Unfortunately, ABRT fails to create the backtrace, apparently because of SELinux. Is there anything I can do to fix this?

août 23 18:18:03 milan kernel: audit: type=1104 audit(1440346681.916:573): pid=2791 uid=0 auid=1000 ses=1 subj=system_u:system_r:xdm_t:s0-s0:c0.c1023
août 23 18:18:03 milan kernel: audit: type=1113 audit(1440346681.916:572): pid=2791 uid=0 auid=1000 ses=1 subj=system_u:system_r:xdm_t:s0-s0:c0.c1023
août 23 18:18:03 milan kernel: audit: type=1106 audit(1440346681.916:571): pid=2791 uid=0 auid=1000 ses=1 subj=system_u:system_r:xdm_t:s0-s0:c0.c1023
août 23 18:18:03 milan kernel: audit_printk_skb: 3 callbacks suppressed
août 23 18:18:03 milan kde4-rkward.desktop[3966]: Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QStri
août 23 18:17:51 milan audit[1]: <audit-1130> pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-journal-f
août 23 18:17:51 milan systemd[1]: Started Flush Journal to Persistent Storage.
août 23 18:17:51 milan audit[1]: <audit-1130> pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-journald 
août 23 18:17:48 milan audit: <audit-1305> audit_enabled=1 old=1 auid=4294967295 ses=4294967295 subj=system_u:system_r:syslogd_t:s0 res=1
août 23 18:17:48 milan audit[1]: <audit-1131> pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-journald 
août 23 18:17:48 milan audit[1]: <audit-1130> pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-journald 
août 23 18:17:48 milan audit[1]: <audit-1131> pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-journal-f
août 23 18:17:48 milan audit[1]: <audit-1131> pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-journald 
août 23 18:17:47 milan audit: <audit-1327> proctitle=2F7573722F6C6962657865632F616272742D686F6F6B2D63637070003600300034323500300030003134343033343636
août 23 18:17:47 milan audit[4089]: <audit-1300> arch=c000003e syscall=61 success=no exit=-13 a0=1a9 a1=7ffee40b780c a2=0 a3=0 items=0 ppid=3880 pid=
août 23 18:17:47 milan audit[4089]: <audit-1400> avc:  denied  { sigchld } for  pid=4089 comm="abrt-hook-ccpp" scontext=system_u:system_r:syslogd_t:s
août 23 18:17:07 milan audit[1]: <audit-1131> pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=NetworkManager-di
août 23 18:16:57 milan audit[1]: <audit-1131> pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-update-ut
août 23 18:16:57 milan audit[1]: <audit-1130> pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-update-ut
août 23 18:16:57 milan audit[425]: <audit-1701> auid=4294967295 uid=0 gid=0 ses=4294967295 subj=system_u:system_r:syslogd_t:s0 pid=425 comm="systemd-
août 23 18:16:41 milan audit[4060]: <audit-1129> pid=4060 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='old-level=N new-
août 23 18:16:41 milan audit[1]: <audit-1130> pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=sm-client comm="s
août 23 18:16:40 milan audit[1]: <audit-1130> pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=sendmail comm="sy
août 23 18:16:08 milan audit[1]: <audit-1131> pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-localed c
août 23 18:17:51 milan systemd[1]: Starting Flush Journal to Persistent Storage...
août 23 18:17:47 milan abrt-hook-ccpp[4089]: Failed to create core_backtrace: waitpid failed: Permission denied
août 23 18:16:55 milan systemd[1]: systemd-journald.service watchdog timeout (limit 1min)!
août 23 18:16:41 milan systemd[1]: Starting Update UTMP about System Runlevel Changes...
août 23 18:16:41 milan systemd[1]: Starting Graphical Interface.
août 23 18:16:41 milan systemd[1]: Reached target Graphical Interface.
août 23 18:16:41 milan systemd[1]: Starting Multi-User System.
août 23 18:16:41 milan systemd[1]: Reached target Multi-User System.
août 23 18:16:41 milan systemd[1]: Started Sendmail Mail Transport Client.
août 23 18:16:40 milan systemd[1]: Started Sendmail Mail Transport Agent.
août 23 18:16:40 milan systemd[1]: PID file /run/sendmail.pid not readable (yet?) after start.
août 23 18:16:05 milan realmd[2722]: stopping service
août 23 18:17:51 milan kernel: audit: type=1130 audit(1440346671.580:569): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s
août 23 18:16:41 milan sm-msp-queue[4058]: starting daemon (8.15.2): queueing@01:00:00
août 23 18:16:41 milan sm-msp-queue[3851]: unable to qualify my own domain name (milan) -- using short name
août 23 18:16:40 milan sendmail[4047]: starting daemon (8.15.2): SMTP+queueing@01:00:00
août 23 18:16:40 milan sendmail[3839]: unable to qualify my own domain name (milan) -- using short name
août 23 18:17:51 milan systemd-journal[4164]: Journal started
août 23 18:17:51 milan kernel: audit: type=1305 audit(1440346668.021:568): audit_enabled=1 old=1 auid=4294967295 ses=4294967295 subj=system_u:system_
août 23 18:17:51 milan kernel: audit: type=1131 audit(1440346668.011:567): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s
août 23 18:17:51 milan kernel: audit: type=1130 audit(1440346668.011:566): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s
août 23 18:17:51 milan kernel: audit: type=1131 audit(1440346668.011:565): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s
août 23 18:17:51 milan kernel: audit: type=1131 audit(1440346668.009:564): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s
août 23 18:17:51 milan kernel: audit: type=1327 audit(1440346667.559:563): proctitle=2F7573722F6C6962657865632F616272742D686F6F6B2D636370700036003000
août 23 18:17:51 milan kernel: audit: type=1300 audit(1440346667.559:563): arch=c000003e syscall=61 success=no exit=-13 a0=1a9 a1=7ffee40b780c a2=0 a
août 23 18:17:51 milan kernel: audit: type=1400 audit(1440346667.559:563): avc:  denied  { sigchld } for  pid=4089 comm="abrt-hook-ccpp" scontext=sys
août 23 18:17:51 milan kernel: audit: type=1131 audit(1440346627.522:562): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s
août 23 18:17:51 milan kernel: audit: type=1131 audit(1440346617.691:561): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s
août 23 18:17:51 milan kernel: audit: type=1130 audit(1440346617.691:560): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s
août 23 18:17:51 milan kernel: audit: type=1701 audit(1440346617.688:559): auid=4294967295 uid=0 gid=0 ses=4294967295 subj=system_u:system_r:syslogd_
août 23 18:17:51 milan kernel: audit: type=1129 audit(1440346601.417:558): pid=4060 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_
août 23 18:17:51 milan kernel: audit: type=1130 audit(1440346601.410:557): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s
août 23 18:17:51 milan kernel: audit: type=1130 audit(1440346600.272:556): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s
août 23 18:17:51 milan kernel: audit: type=1131 audit(1440346568.917:555): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s
Comment 1 Jakub Filak 2015-08-24 06:11:37 EDT
Thank you for the report. The AVC should be fixed by selinux-policy-3.13.1-128.12.fc22 (bug #1245477). What is your version of selinux-policy?
Comment 2 Milan Bouchet-Valat 2015-08-24 09:49:32 EDT
Ah, funny, looks like I reported it one day too early. I'm using 3.13.1-128.10.

*** This bug has been marked as a duplicate of bug 1245477 ***

Note You need to log in before you can comment on or make changes to this bug.