Bug 1256064 - git .desktop file shows ico file as icon [NEEDINFO]
git .desktop file shows ico file as icon
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: git (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: pstodulk
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-23 14:55 EDT by RudraB
Modified: 2016-07-01 05:26 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-01 05:26:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tmz: needinfo? (bnrj.rudra)


Attachments (Terms of Use)

  None (edit)
Description RudraB 2015-08-23 14:55:35 EDT
Description of problem:
The Icon category of git-gui.desktop  file shows .ico extension. Isnt it should be 

$grep Icon git-gui.desktop 
Icon=/usr/share/git-gui/lib/git-gui.ico

Version-Release number of selected component (if applicable):
git-gui-2.4.3-6.fc22.noarch

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Fedora Admin XMLRPC Client 2016-03-16 14:23:44 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Todd Zullinger 2016-04-11 13:38:31 EDT
Can you provide more details on the problem you're reporting?

I can see that the git-gui.desktop file uses a .ico file for the Icon, but that file is what upstream provides, it's installed along with the package, and the icon shows up when I view the git-gui entry in Gnome.  So I'm not sure where there is a bug.
Comment 3 pstodulk 2016-07-01 05:26:49 EDT
Icon isn't showed with removed extension ".ico", so there should be used really whole path with whole filename. 

Maybe it's because git uses "non-standard" location instead of "/usr/share/icons/*", don't know which subdirectory should be used correctly and if it works. But as I see, I have more APP which uses own directory for icons, so I don't see benefit of moving the file.

Note You need to log in before you can comment on or make changes to this bug.