Bug 1256070 - hp-plugin (3.15.7) hangs on, after accept the license terms (LaserJet Pro MFP M177fw)
hp-plugin (3.15.7) hangs on, after accept the license terms (LaserJet Pro MFP...
Status: CLOSED DUPLICATE of bug 1249414
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
22
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-23 15:52 EDT by vol
Modified: 2015-08-24 04:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-24 04:27:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vol 2015-08-23 15:52:08 EDT
Description of problem:

I'm trying to setup the color LaserJet Pro MFP M177fw. 
Hplip 3.15.7 vers.2.1 is installed. 

Running the command hp-setup -i, will install the hp-plugin, but doesn't it. 

Independent, if I choose the download of the plug-in from HP or give the path to the plug-in manually, the result it's the same: After i accept the license terms the install of the plugin starts, but never ends. It's like a loop.

I need to interrupt the process with Ctrl+C or use the kill command.

Here is the result:

|^CTraceback (most recent call last):
  File "./plugin_install.py", line 184, in <module>
    if not installPlugin():
  
File "./plugin_install.py", line 56, in installPlugin
    status, output = utils.run(cmd, passwordObj)

File "/usr/share/hplip/base/utils.py", line 1283, in run
    i = child.expect(EXPECT_LIST)

File "/usr/share/hplip/base/pexpect/__init__.py", line 1418, in expect
    timeout, searchwindowsize)

File "/usr/share/hplip/base/pexpect/__init__.py", line 1433, in expect_list
    timeout, searchwindowsize)

File "/usr/share/hplip/base/pexpect/__init__.py", line 1502, in expect_loop
    c = self.read_nonblocking(self.maxread, timeout)

File "/usr/share/hplip/base/pexpect/__init__.py", line 901, in read_nonblocking
    r, w, e = self.__select([self.child_fd], [], [], timeout)

File "/usr/share/hplip/base/pexpect/__init__.py", line 1687, in __select
    return select.select(iwtd, owtd, ewtd, timeout)

KeyboardInterrupt

error: Python gobject/dbus may be not installed

Traceback (most recent call last):

File "/bin/hp-plugin", line 368, in <module>
pluginObj.run_plugin(plugin_path, mode)

File "/usr/share/hplip/installer/pluginhandler.py", line 366, in run_plugin
    os.chdir(cwd)  

It's impossible to install the plugin.

Thanks
Comment 1 Jiri Popelka 2015-08-24 04:27:20 EDT

*** This bug has been marked as a duplicate of bug 1249414 ***

Note You need to log in before you can comment on or make changes to this bug.