Bug 125612 - works for root only
works for root only
Status: CLOSED DUPLICATE of bug 121511
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-09 08:32 EDT by Igor Mozetic
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Igor Mozetic 2004-06-09 08:32:39 EDT
Description of problem:
Scanner detection (USB, UMAX Astra 3400) works for root only.
Probably just permissions problem, but its not obvious
what should one do. Adding users to a group (which?)...

Version-Release number of selected component (if applicable):
sane-backends-1.0.13-7
xsane-gimp-0.92-10
sane-frontends-1.0.11-4
xsane-0.92-10

How reproducible:
Always

Steps to Reproduce:
1. run xsane as non-root user
2. Pop-up window: no device availabe
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Igor Mozetic 2004-06-10 09:38:14 EDT
The problem is apparently in the hotplug tool.
Namely, one can "chmod a+rw /proc/bus/usb/003/002"
after finding the file name with sane-find-scanner,
and xsane works for non-root as well.
However, this must be done after each reboot, see
http://www.sane-project.org/README.linux
Comment 2 Tim Waugh 2004-06-24 12:34:10 EDT
We ship a hotplug script for SANE: you can power off and on the device
(or unplug/re-insert the USB connector) to achieve what you want. 
This needs to be solved properly, and I'm told that udev will
eventually do that.
Comment 3 Harald Hoyer 2004-06-25 02:38:53 EDT
I think, this is solved better by HAL, as scanners do not identify
themselves easily as "scanner"s. Udev needs strict "rules"
(identifier) to e.g. symlink a device node to /dev/scanner.
Comment 4 Harald Hoyer 2004-07-12 08:59:53 EDT
also pam_console is good for that...
Comment 5 Tim Waugh 2004-07-12 09:36:12 EDT
No, it isn't -- that's what we use right now.
Comment 6 Tim Waugh 2004-07-12 11:19:49 EDT

*** This bug has been marked as a duplicate of 121511 ***
Comment 7 Red Hat Bugzilla 2006-02-21 14:04:00 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.