Bug 1256214 - [ ERROR ] Failed to execute stage 'Setup validation': Failed checking Engine database: [u'']
[ ERROR ] Failed to execute stage 'Setup validation': Failed checking Engine ...
Status: CLOSED DUPLICATE of bug 1254639
Product: oVirt
Classification: Community
Component: ovirt-engine-installer (Show other bugs)
3.6
x86_64 Linux
unspecified Severity urgent
: ---
: 3.6.0
Assigned To: Martin Perina
Pavel Stehlik
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-24 01:21 EDT by Nikolai Sednev
Modified: 2015-08-25 04:13 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-25 04:13:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine_logs (74.47 KB, application/x-gzip)
2015-08-24 01:21 EDT, Nikolai Sednev
no flags Details

  None (edit)
Description Nikolai Sednev 2015-08-24 01:21:54 EDT
Created attachment 1066205 [details]
engine_logs

Description of problem:
ovirt-vmconsole fails to get installed during engine-setup. 

[root@nsednev-rhevm-smoketests-3-5 ~]# engine-setup 
[ INFO  ] Stage: Initializing                       
[ INFO  ] Stage: Environment setup                  
          Configuration files: ['/etc/ovirt-engine-setup.conf.d/10-packaging-wsp.conf', '/etc/ovirt-engine-setup.conf.d/10-packaging.conf', '/etc/ovirt-engine-setup.conf.d/20-setup-ovirt-post.conf']                                                                                                                
          Log file: /var/log/ovirt-engine/setup/ovirt-engine-setup-20150824080613-j3lju0.log                                                               
          Version: otopi-1.4.0_master (otopi-1.4.0-0.0.1.master.el6ev)                                                                                     
[ INFO  ] Stage: Environment packages setup                                                                                                                
[ INFO  ] Stage: Programs detection                                                                                                                        
[ INFO  ] Stage: Environment setup                                                                                                                         
[ INFO  ] Stage: Environment customization                                                                                                                 
                                                                                                                                                           
          Welcome to the RHEV 3.6 setup/upgrade.                                                                                                           
          Please read the RHEV 3.6 install guide                                                                                                           
          https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html/Installation_Guide/index.html.                     
          Please refer to the RHEV Upgrade Helper application                                                                                              
          https://access.redhat.com/labs/rhevupgradehelper/ which will guide you in the upgrading process.                                                 
          Would you like to proceed? (Yes, No) [Yes]:                                                                                                      
                                                                                                                                                           
          --== PRODUCT OPTIONS ==--                                                                                                                        
                                                                                                                                                           
          Configure VM Console Proxy on this host (Yes, No) [Yes]:                                                                                         
                                                                                                                                                           
          --== PACKAGES ==--                                                                                                                               
                                                                                                                                                           
[ INFO  ] Checking for product updates...                                                                                                                  
[ INFO  ] No product updates found                                                                                                                         
                                                                                                                                                           
          --== ALL IN ONE CONFIGURATION ==--                                                                                                               
                                                                                                                                                           
                                                                                                                                                           
          --== NETWORK CONFIGURATION ==--                                                                                                                  
                                                                                                                                                           
          Setup can automatically configure the firewall on this system.                                                                                   
          Note: automatic configuration of the firewall may overwrite current settings.                                                                    
          Do you want Setup to configure the firewall? (Yes, No) [Yes]:                                                                                    
[ INFO  ] iptables will be configured as firewall manager.                                                                                                 
          Engine vmconsole port [2222]:                                                                                                                    
                                                                                                                                                           
          --== DATABASE CONFIGURATION ==--                                                                                                                 
                                                                                                                                                           
                                                                                                                                                           
          --== OVIRT ENGINE CONFIGURATION ==--                                                                                                             
                                                                                                                                                           
                                                                                                                                                           
          --== STORAGE CONFIGURATION ==--                                                                                                                  
                                                                                                                                                           
                                                                                                                                                           
          --== PKI CONFIGURATION ==--                                                                                                                      
                                                                                                                                                           
                                                                                                                                                           
          --== APACHE CONFIGURATION ==--                                                                                                                   


          --== SYSTEM CONFIGURATION ==--


          --== MISC CONFIGURATION ==--


          --== END OF CONFIGURATION ==--

[ INFO  ] Stage: Setup validation
          During execution engine service will be stopped (OK, Cancel) [OK]:
          Generated iptables rules are different from current ones.
          Do you want to review them? (Yes, No) [No]:
[ INFO  ] Cleaning stale zombie tasks and commands

          --== CONFIGURATION PREVIEW ==--

          Default SAN wipe after delete           : False
          Firewall manager                        : iptables
          Update Firewall                         : True
          Host FQDN                               : nsednev-rhevm-smoketests-3-5.scl.lab.tlv.redhat.com
          Engine database secured connection      : False
          Engine database host                    : localhost
          Engine database user name               : engine
          Engine database name                    : engine
          Engine database port                    : 5432
          Engine database host name validation    : False
          Engine installation                     : True
          PKI organization                        : scl.lab.tlv.redhat.com
          Configure WebSocket Proxy               : False
          Engine Host FQDN                        : nsednev-rhevm-smoketests-3-5.scl.lab.tlv.redhat.com

          Please confirm installation settings (OK, Cancel) [OK]:
[ INFO  ] Cleaning async tasks and compensations
[ INFO  ] Unlocking existing entities
[ INFO  ] Checking the Engine database consistency
[ ERROR ] Failed to execute stage 'Setup validation': Failed checking Engine database: [u'']
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20150824080613-j3lju0.log
[ INFO  ] Generating answer file '/var/lib/ovirt-engine/setup/answers/20150824080704-setup.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Execution of setup failed

Version-Release number of selected component (if applicable):
ovirt-vmconsole-1.0.0-0.0.master.el6ev.noarch
rhevm-3.6.0-0.12.master.el6.noarch
rhevm-guest-agent-common-1.0.11-1.el6ev.noarch
qemu-guest-agent-0.12.1.2-2.479.el6.x86_64
Linux version 2.6.32-504.el6.x86_64 (mockbuild@x86-023.build.eng.bos.redhat.com) (gcc version 4.4.7 20120313 (Red Hat 4.4.7-11) (GCC) ) #1 SMP Tue Sep 16 01:56:35 EDT 2014

How reproducible:
100%

Steps to Reproduce:
1.Freshly install RHEL6.7 with all latest updates to VM running on some host.
2.Install the RHEVM3.6 engine on VM (engine-setup without ovirt-vmconsole).
3.Install ovirt-vmconsole on VM.
4.Run engine-setup again to enable the ovirt-vmconsole on it.

Actual results:
Engine setup fails.
[ ERROR ] Failed to execute stage 'Setup validation': Failed checking Engine database: [u'']  
[ ERROR ] Execution of setup failed          

Expected results:
Engine setup should pass without errors.

Additional info:
logs from the engine attached.
Comment 1 Alon Bar-Lev 2015-08-24 01:55:08 EDT
Please do not open downstream bug unless downstream component or downstream specific.

Has nothing to do with vmconsole:

2015-08-24 08:07:04 DEBUG otopi.plugins.ovirt_engine_setup.ovirt_engine.upgrade.dbvalidations plugin.execute:940 execute-output: ['/usr/share/ovirt-engine/setup/dbutils/validatedb.sh', '--user=engine', '--host=localhost', '--port=5432', '--database=engine', '--log=/var/log/ovirt-engine/setup/ovirt-engine-setup-20150824080613-j3lju0.log'] stderr:
ERROR:  relation "group_attributes" does not exist
LINE 1: select  (group_id)  from group_attributes where  (group_id) ...
                                 ^
QUERY:  select  (group_id)  from group_attributes where  (group_id) IS NOT NULL and  (group_id)  not in (select group_id from groups);
CONTEXT:  PL/pgSQL function "fn_db_validate_fks" line 40 at EXECUTE statement

Sandro, you should probably throw exception that is human readable, this is not a debug, error is probably in stderr, and format should not be list/tuple.
Comment 2 Eli Mesika 2015-08-25 04:13:14 EDT

*** This bug has been marked as a duplicate of bug 1254639 ***

Note You need to log in before you can comment on or make changes to this bug.