This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 125623 - FC2 box upgraded from RH9 has subversion / db4 error: 'Bad database version: compiled with 4.2.52, running against 4.0.14'
FC2 box upgraded from RH9 has subversion / db4 error: 'Bad database version: ...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: subversion (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-09 10:43 EDT by Chris Croome
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-09 10:47:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Croome 2004-06-09 10:43:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040124

Description of problem:
I have just upgraded a Red Hat 9 box to Fedora Core 2 and have a
subversion problem that I can't solve (I did have another problem with
the AMD K6 300 but switching the disks into a celerol fixed that
problem, see: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=91933)

I have email the subversion dev list about this:

http://article.gmane.org/gmane.comp.version-control.subversion.devel/47130

Since then I have worked out how to test this bug:

1. Create a test repo, eg:

$ cd /tmp
$ svnadmin create test

2. Try to open a svn shell using the test repo:

$ /usr/share/doc/subversion-1.0.4/tools/examples/svnshell.py /tmp/test/

This generates this error:

Traceback (most recent call last):
  File "/usr/share/doc/subversion-1.0.4/tools/examples/svnshell.py",
line 304, in ?
    main()
  File "/usr/share/doc/subversion-1.0.4/tools/examples/svnshell.py",
line 301, in main
    core.run_app(SVNShell, sys.argv[1])
  File
"/usr/src/build/398401-i386/install/usr/lib/python2.3/site-packages/svn/core.py",
line 33, in run_app
  File "/usr/share/doc/subversion-1.0.4/tools/examples/svnshell.py",
line 36, in __init__
    self.fs_ptr = repos.svn_repos_fs(repos.svn_repos_open(path, pool))
libsvn._core.SubversionException: ('Bad database version: compiled
with 4.2.52, running against 4.0.14', 160000)

However when I try this on a box that has been upgraded from Fedora 1
to Fedora 2 and has never had 3rd party subversion RPMs on it I don't
get the same problem, I get a working shell:

$ /usr/share/doc/subversion-1.0.4/tools/examples/svnshell.py /tmp/test/
<rev: 0 />$ 

I never use the svn shell -- this is just a good way to illistrate the
problem. I found the problem when trying to get SVN::Web from CPAN
running.

I have tried uninstalling subversion running updatedb and looking if
there is any old files on the file system, there was a
/usr/lib/subversion/ so I deleted that and then reinstalled the
subversion RPMs but this hasn't helped.

I *think* the problem is a dependancy somewhere on an old version of
db4 but I'm not sure what to do next... :-/


Version-Release number of selected component (if applicable):
subversion-1.0.4-1

How reproducible:
Always

Steps to Reproduce:
1. cd /tmp; svnadmin create test
2. /usr/share/doc/subversion-1.0.4/tools/examples/svnshell.py /tmp/test/
3. Error is generated
    

Actual Results:  Traceback (most recent call last):
  File "/usr/share/doc/subversion-1.0.4/tools/examples/svnshell.py",
line 304, in ?
    main()
  File "/usr/share/doc/subversion-1.0.4/tools/examples/svnshell.py",
line 301, in main
    core.run_app(SVNShell, sys.argv[1])
  File
"/usr/src/build/398401-i386/install/usr/lib/python2.3/site-packages/svn/core.py",
line 33, in run_app
  File "/usr/share/doc/subversion-1.0.4/tools/examples/svnshell.py",
line 36, in __init__
    self.fs_ptr = repos.svn_repos_fs(repos.svn_repos_open(path, pool))
libsvn._core.SubversionException: ('Bad database version: compiled
with 4.2.52, running against 4.0.14', 160000)

Expected Results:  <rev: 0 />$ 

Additional info:
Comment 1 Joe Orton 2004-06-09 10:47:57 EDT
If you've previously had Subversion 1.0.4 RPMs on this box maybe they
are still there.  Otherwise try fedora-list@redhat.com for help.

Try:

# rpm --erase subversion mod_dav_svn subversion-devel subversion-perl
# up2date subversion mod_dav_svn subversion-devel subversion-perl

to ensure you're running real Fedora Subversion packages.
Comment 2 Chris Croome 2004-06-09 10:52:08 EDT
I did try that several time already and I have just done it again and
still I have the same problem...
Comment 3 Chris Croome 2004-06-09 10:53:54 EDT
# rpm -qi subversion
Name        : subversion                   Relocations: (not relocatable)
Version     : 1.0.4                             Vendor: Red Hat, Inc.
Release     : 1                             Build Date: Sat 22 May
2004 10:35:57 BST
Install Date: Wed 09 Jun 2004 15:51:30 BST      Build Host:
bugs.build.redhat.com
Group       : Development/Tools             Source RPM:
subversion-1.0.4-1.src.rpm
Size        : 3323222                          License: BSD
Signature   : DSA/SHA1, Thu 27 May 2004 17:37:58 BST, Key ID
b44269d04f2a6fd2
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://subversion.tigris.org/
Summary     : A Concurrent Versioning system similar to, but better
than, CVS.
Comment 4 Joe Orton 2004-06-09 10:56:43 EDT
Then something else is bringing an old libdb4 into the Python process,
either you still have an old python package or one of the python
modules getting loaded is an old version linked aginst the old lidb4.

rpm -qai python\*
Comment 5 Chris Croome 2004-06-09 10:59:14 EDT
OK, I have tried that:

# rpm -qai python\*
Name        : python                       Relocations: (not relocatable)
Version     : 2.3.3                             Vendor: Red Hat, Inc.
Release     : 6                             Build Date: Fri 07 May
2004 15:55:11 BST
Install Date: Tue 08 Jun 2004 12:50:21 BST      Build Host:
tweety.build.redhat.com
Group       : Development/Languages         Source RPM:
python-2.3.3-6.src.rpm
Size        : 21168784                         License: PSF - see LICENSE
Signature   : DSA/SHA1, Fri 07 May 2004 17:27:24 BST, Key ID
b44269d04f2a6fd2
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.python.org/
Summary     : An interpreted, interactive, object-oriented programming
language.
Description :
Python is an interpreted, interactive, object-oriented programming
language often compared to Tcl, Perl, Scheme, or Java. Python includes
modules, classes, exceptions, very high-level dynamic data types, and
dynamic typing. Python supports interfaces to many system calls and
libraries, as well as to various windowing systems (X11, Motif, Tk,
Mac, and MFC).

Programmers can write new built-in modules for Python in C or C++.
Python can be used as an extension language for applications that need
a programmable interface. This package contains most of the standard
Python modules, as well as modules for interfacing to the Tix widget
set for Tk and RPM.

Note that documentation for Python is provided in the python-docs
package.
Name        : python-optik                 Relocations: (not relocatable)
Version     : 1.4.1                             Vendor: Red Hat, Inc.
Release     : 5                             Build Date: Tue 17 Feb
2004 06:50:09 GMT
Install Date: Tue 08 Jun 2004 13:00:29 BST      Build Host:
loma.devel.redhat.com
Group       : Development/Libraries         Source RPM:
python-optik-1.4.1-5.src.rpm
Size        : 193466                           License: BSD
Signature   : DSA/SHA1, Fri 07 May 2004 00:10:15 BST, Key ID
b44269d04f2a6fd2
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://optik.sourceforge.net/
Summary     : Powerful, flexible, easy-to-use, command-line parsing
library
Description :
Optik is a powerful, flexible, extensible, easy-to-use
command-line parsing library for Python.  Using Optik, you
can add intelligent, sophisticated handling of command-line
options to your scripts with very little overhead.
Comment 6 Chris Croome 2004-06-09 11:03:49 EDT
I don't know if this is relavent but on my desktop machine which is a
FC2 upgraded from FC1 I can uninstall compat-db without a problem.

However on the machine that is causing the problem I can't because
httpd depends on it, however I _do_ have httpd installed on the
machine without compat-db:

# rpm -e compat-db
error: Failed dependencies:
        libdb-4.0.so is needed by (installed) apr-util-0.9.5-0.1

# rpm -e apr-util
error: Failed dependencies:
        libaprutil-0.so.0 is needed by (installed) httpd-2.0.49-4
        libaprutil-0.so.0 is needed by (installed) mod_perl-1.99_12-2.1
        libaprutil-0.so.0 is needed by (installed) subversion-1.0.4-1
        libaprutil-0.so.0 is needed by (installed) subversion-perl-1.0.4-1
        apr-util = 0.9.5 is needed by (installed) apr-util-devel-0.9.5-0.1
Comment 7 Joe Orton 2004-06-09 11:08:03 EDT
That's your problem; apr-util 0.9.5 is not a Fedora package.  You'll
have to --nodeps the erase and install the real package.
Comment 8 Joe Orton 2004-06-09 11:08:41 EDT
And you'd be well-advised to do the same for the apr package and any
other third-party packages you might have on the system.
Comment 9 Chris Croome 2004-06-09 11:09:45 EDT
Doh!

You are right, I'll track down all the non-Fedora RPMs...

# rpm -qi apr-util
Name        : apr-util                     Relocations: (not relocatable)
Version     : 0.9.5                             Vendor: (none)
Release     : 0.1                           Build Date: Sat 01 Nov
2003 18:58:25 GMT
Install Date: Fri 06 Feb 2004 11:46:08 GMT      Build Host:
amd.summersoft.fay.ar.us
Group       : System Environment/Libraries   Source RPM:
apr-util-0.9.5-0.1.src.rpm
Size        : 772894                           License: Apache
Software License
Signature   : (none)
URL         : http://apr.apache.org/
Summary     : Apache Portable Runtime Utility library
Description :
The mission of the Apache Portable Runtime (APR) is to provide a
free library of C data structures and routines.  This library
contains additional utility interfaces for APR; including support
for XML, LDAP, database interfaces, URI parsing and more.

Note You need to log in before you can comment on or make changes to this bug.