Bug 1256231 - Edit host dialog gets stuck
Edit host dialog gets stuck
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
3.6
x86_64 Linux
unspecified Severity low
: ---
: 3.6.0
Assigned To: Piotr Kliczewski
movciari
infra
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-24 02:45 EDT by Meni Yakove
Modified: 2016-02-10 14:31 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-04 09:22:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine, vdsm and supervdsm logs (1.08 MB, application/zip)
2015-08-24 02:47 EDT, Meni Yakove
no flags Details

  None (edit)
Description Meni Yakove 2015-08-24 02:45:46 EDT
Description of problem:
Cannot switch host from Json RPC to XML RPC, the edit host dialog is stuck after pressing OK

Version-Release number of selected component (if applicable):
rhevm-3.6.0-0.11.master.el6.noarch
vdsm-4.17.3-1.el7ev.noarch


Steps to Reproduce:
1. Edit host and remove the mark from advance parameters > use JSON protocol > OK
Comment 1 Meni Yakove 2015-08-24 02:47:58 EDT
Created attachment 1066228 [details]
engine, vdsm and supervdsm logs
Comment 2 Oved Ourfali 2015-08-25 02:03:21 EDT
You shouldn't move hosts to xmlrpc in cluster level 3.6 (I think we have a bug in order to prevent that from being enabled in the UI).

However, it shouldn't get stuck.

Piotr - can you take a look and understand why it is stuck? In the meantime, it would be good to cover the other bug and just disable it...
Comment 3 Piotr Kliczewski 2015-08-25 03:01:41 EDT
Sure, will change it.
Comment 4 Piotr Kliczewski 2015-08-27 04:33:57 EDT
Please check latest master or 3.6. I tested both and after changing protocol I can see that it works. Host edit dialog is a bit to slow but a host is properly updated.
Comment 5 Piotr Kliczewski 2015-09-04 09:22:32 EDT
I am closing this bug as "not a bug". Please reopen if you notice the issue again.
Comment 6 Pavel Stehlik 2015-11-06 03:29:07 EST
I'd rather see the BZ to be closed as CURRENTRELEASE - based on c#4 it works, current version doesn't even offer that change on 3.6 Cluster - so something changed.
Comment 7 Oved Ourfali 2015-11-06 03:48:03 EST
Pavel, what's working is that it isn't stuck as Meni said. However, you still won't be able to switch to xmlrpc. 

So the bug wasn't fixed, as it wasn't a bug. 

Do you think it should be back on notabug?
Comment 8 Pavel Stehlik 2015-11-06 03:52:53 EST
It was stuck as Meni said in the time he tested it.
 Since then someone change the code, thus I am voting for using proper status from https://bugzilla.redhat.com/page.cgi?id=fields.html#bug_status
(I also think UPSTREAM doesn't make sense here).
Comment 9 Oved Ourfali 2015-11-06 04:51:19 EST
Just making sure you're aware that you still won't be able to switch protocols in 3.6. By declaring this is fixed, someone might think it is possible.

Note You need to log in before you can comment on or make changes to this bug.