Bug 125625 - yum has packages to update, but returns after doing little
yum has packages to update, but returns after doing little
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-09 11:06 EDT by Nathan G. Grennan
Modified: 2014-01-21 17:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-09 21:27:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum -d 6 -y update output (18.19 KB, application/octet-stream)
2004-06-09 18:29 EDT, Nathan G. Grennan
no flags Details

  None (edit)
Description Nathan G. Grennan 2004-06-09 11:06:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040522 Galeon/1.3.15

Description of problem:
Here is the output from yum:

[root@ns2 ~]$ yum -y update
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - i386 - Base
Server: Fedora Core 2 - i386 - Testing
Server: Fedora Core 2 - i386 - Released Updates
Server: Mesh Linux / server for Fedora Core 2
Finding updated packages
Downloading needed headers
Resolving dependencies
Dependencies resolved
I will do the following:
Downloading Packages
Running test transaction:
Test transaction complete, Success!
Transaction(s) Complete
[root@ns2 ~]$



I know it should at the very least by updating the kernel package if
not other packages.

Version-Release number of selected component (if applicable):
yum-2.0.7-1.2.1

How reproducible:
Always

Steps to Reproduce:
1. yum -y update
2.
3.
    

Actual Results:  No packages downloaded and installed

Expected Results:  Packages downloaded and installed

Additional info:

It isn't an offical yum package, but then I just rebuilt it to add a
custom yum.conf. I also use this package on many other systems running
FC2 without a problem.

I have tried looking at the rpm database and rebuilding it, with no luck.
Comment 1 Nathan G. Grennan 2004-06-09 11:08:51 EDT
I have also tried rm -rf /var/cache/yum/*  without results.
Comment 2 Jeff Johnson 2004-06-09 17:25:17 EDT
Check your configurqation. If you are looking at an
older or empty repo, you will see the behavior above.

Try adding -d 5 and examine the debugging spew to see
what is happening.
Comment 3 Nathan G. Grennan 2004-06-09 18:19:21 EDT
I figured out the problem. Not sure it if is a rpm bug, yum bug, or
both. The two systems I found with the problem were at one time i586
systems. After install I moved the hard drives to better hardware.
They became i686 systems. When I commented out exactarch=1 in yum.conf
it started to work, but instead of downloading a i686 kernel rpm it
started to download a i586 kernel rpm. I stopped it and checked both
the kernel package that was installed and /proc/cpuinfo. Both reported
i686. So then I did a grep -r i586 /etc  and found /etc/rpm/platform
with i586-redhat-linux instead of i686-redhat-linux. I changed the
file to i686-redhat-linux, and now yum works with exactarch=1.
Comment 4 Nathan G. Grennan 2004-06-09 18:29:06 EDT
Created attachment 101017 [details]
yum -d 6 -y update  output
Comment 5 Jeff Johnson 2004-06-09 21:27:19 EDT
Hmmm, it's hard for an application to figger when the arch changes
because the disk moved, most apps lack inertial sensors ;-)

Yes, /etc/rpm/platform needs change, as that sets the arch
for the platform. Usually anaconda writes that file ...
Comment 6 Seth Vidal 2004-06-10 01:40:27 EDT
ok so I figured out why it's saying this.

yum is going through the deps, realizing there is nothing, with
exactarch=1 set, that it can do with the available packages and
available system (in short changing archs w/o completely changing
archs confused the hell out of it :), and it should be exiting, but
it's not it's saying, do whatever is left, but there is nothing left
to do. :)

I've checked a fix into yum cvs to address this.


Note You need to log in before you can comment on or make changes to this bug.