Bug 125627 - Directory listing erratic on NFS mounted volumes
Directory listing erratic on NFS mounted volumes
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
All Linux
medium Severity high
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-09 11:17 EDT by Frank Bures
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 00:39:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Bures 2004-06-09 11:17:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.4.1)
Gecko/20031121

Description of problem:
System running FC2 is NFS mounting an IRIX6.5.19f volume.
If such volume's directories are listed from a FC2 shell directly,
there are no problems.  If a program is used to list the directories,
some directory items, be it files or subdirectories, will be missing
from the list.  Programs used to list the directories were pine 4.60
built from source,  mutt-1.4.1-6 and VMwareWorkstation-4.5.1.  All
these programs behave the same - directory listings of mounted volumes
are erratic.

Version-Release number of selected component (if applicable):
fedora core 2

How reproducible:
Always

Steps to Reproduce:
1. NFS mount volume on IRIX 6.5.19f from Fedora Core 2 
2. run mutt (pine) over that volume
3. list directory using mutt (pine)

    

Actual Results:  Certain directory items (subdirectories, files) are
missing from the list

Expected Results:  All directory items should be listed

Additional info:

Directory listing works OK from a shell.  However, when a program is
used to list directories, the erroneous results occurr.  I did not
investigate, if the problem is caused by autofs, nfs-utils, libraries
or kernel.
I had to downgrade the installation to FC1.
Comment 1 Frank Bures 2004-06-14 13:51:08 EDT
I tested the bug on a completely different HW (Pentium 4 as opposed to
Athlon, single CPU as opposed to SMP).  It behaves exactly the same.
I also tried to downgrade autofs, nfs-utils and initscripts to
versions from FC1 that is known to work.  No effect.

Comment 2 Steve Dickson 2004-06-15 21:42:06 EDT
Is the IRIX fs being exported with -32bitclients? If on 
could you export with 32bitclients set?

Also what are the rest of the export and mount options?
Comment 3 Frank Bures 2004-06-16 10:26:35 EDT
the -32bitclients option is there, and has been there for 
a long time (several years, in fact).  We put it there when we had a
similar problem with one of the RedHat versions.  I do not remember
which one, though.  The problem was that sometimes NFS mounted volumes
could not be listed globally - not even from a shell.
BTW, the FC2 on an x86_64 machine (Dual Opteron) works OK. 
As to the mount options, we use autofs with --nosuid,nodev.
'mount' on the FC2 wosktation returns: automount(pid5270) on
/nfs/irixmachine type autofs (rw,fd=4,pgrp=5270,minproto=2,maxp
roto=4)

Comment 4 Steve Dickson 2004-10-14 17:29:04 EDT
Does this still happen on more recent FC2 kernels?
Comment 5 Frank Bures 2004-10-18 11:50:55 EDT
We have not experienced the problem lately, but we do not have too
many FC2 machines running.  We switched to RH-EL.

Comment 6 Alastair Cousins 2004-11-17 23:44:33 EST
I'm seeing the same behaviour in both Fedora Core 2 & 3 with every
Fedora kernel i've tried (including current). The problem also happens
with the stock kernel.org kernel. 

After doing some research i've tracked down the cause and solution for
my particular system:

The problem only occurs on volumes exported via NFS on an Irix box
that are formatted as XFS version 1. These are older filesystems. The
problem does not occur with XFS version 2 formatted filesystems.
-32bitclients does not fix this particular bug. 

It seems to be related to a glibc bug on Linux which was patched over
in 2.4.x but the patch never made it into the 2.6.x series of kernels
for some reason.

Some applications are statically linked against older glibc's which is
why they exhibit the problem, other software compiled with Fedora does
not. 

The following thread covers the problem and solutions well:

http://groups.google.com/groups?hl=en&lr=&threadm=289EB-83g-11%40gated-at.bofh.it&rnum=4&prev=/groups%3Fhl%3Den%26lr%3D%26scoring%3Dd%26q%3Dxfs%2Birix%2B%2522version%2B2%2522%26btnG%3DSearch
Comment 7 Dave Jones 2005-04-16 00:39:13 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.