Bug 1256300 - Clicking on "Clone this VM" throws "<AutomationEngine> Class [unknown/VM/Provisioning/Profile] not found in MiqAeDatastore" error
Clicking on "Clone this VM" throws "<AutomationEngine> Class [unknown/VM/Prov...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Tina Fitzgerald
Ramesh A
vm:ui
:
Depends On:
Blocks: 1291457
  Show dependency treegraph
 
Reported: 2015-08-24 06:18 EDT by Ramesh A
Modified: 2016-06-29 10:59 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1291457 (view as bug list)
Environment:
Last Closed: 2016-06-29 10:59:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ramesh A 2015-08-24 06:18:24 EDT
Description of problem:
Clicking on "Clone this VM" throws "ERROR -- : <AutomationEngine> Class [unknown/VM/Provisioning/Profile] not found in MiqAeDatastore" in evm.log file

Version-Release number of selected component (if applicable):
5.4.2.0.20150820153254_83e434d

How reproducible:
Very

Steps to Reproduce:
1. Deploy a fresh appliance and manage a provider (say vsphere55)
2. Navigate to Infrastructure ==> Virutal Machine.
3. Select an vm, click on it to go to "VM Summary Page"
4. Click on Lifecycle ==> Clone this VM

Actual results:
throw error in evm.log file stating "<AutomationEngine> Class [unknown/VM/Provisioning/Profile] not found in MiqAeDatastore".  Refer evm.log file for more details.

Expected results:
Should not throw any error message

Additional info:
evm.log:
=======
[----] I, [2015-08-24T05:52:38.626675 #2569:f81eac]  INFO -- : <AutomationEngine> Following Relationship [miqaedb:/unknown/VM/Provisioning/Profile/EvmGroup-super_administrator#get_domains]
[----] E, [2015-08-24T05:52:38.736324 #2569:f81eac] ERROR -- : <AutomationEngine> Class [unknown/VM/Provisioning/Profile] not found in MiqAeDatastore
[----] I, [2015-08-24T05:52:38.736557 #2569:f81eac]  INFO -- : <AutomationEngine> Followed  Relationship [miqaedb:/unknown/VM/Provisioning/Profile/EvmGroup-super_administrator#get_domains]
[----] I, [2015-08-24T05:52:38.736872 #2569:f81eac]  INFO -- : <AutomationEngine> Followed  Relationship [miqaedb:/System/Request/UI_PROVISION_INFO#create]
[----] W, [2015-08-24T05:52:38.739265 #2569:f81eac]  WARN -- : MIQ(Class.get_domain_details) - No Domains matched in Automate Results: <MiqAeWorkspace>
  <MiqAeObject namespace="ManageIQ/System" class="Process" instance="REQUEST">
    <MiqAeAttribute name="ae_provider_category">
      <String>unknown</String>
    </MiqAeAttribute>
    <MiqAeAttribute name="message">
      <String>get_domains</String>
    </MiqAeAttribute>
    <MiqAeAttribute name="miq_server">
      <MiqAeServiceMiqServer object_id="137860940" id="1"/>
    </MiqAeAttribute>
    <MiqAeAttribute name="miq_server_id">
      <String>1</String>
    </MiqAeAttribute>
    <MiqAeAttribute name="object_name">
      <String>REQUEST</String>
    </MiqAeAttribute>
    <MiqAeAttribute name="request">
      <String>UI_PROVISION_INFO</String>
    </MiqAeAttribute>
    <MiqAeAttribute name="user">
      <MiqAeServiceUser object_id="141837560" id="1"/>
    </MiqAeAttribute>
    <MiqAeAttribute name="user_id">
      <String>1</String>
    </MiqAeAttribute>
    <MiqAeObject namespace="ManageIQ/System" class="Request" instance="UI_PROVISION_INFO">
    </MiqAeObject>
  </MiqAeObject>
</MiqAeWorkspace>
Comment 2 Tina Fitzgerald 2015-09-02 11:49:31 EDT
The log message should be removed, but it does not affect provisioning in any way.
Comment 4 CFME Bot 2016-01-19 13:46:06 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/5c8d86b7afb7c9068cf683c1f16c01d642f1c4d5

commit 5c8d86b7afb7c9068cf683c1f16c01d642f1c4d5
Author:     Tina Fitzgerald <tfitzger@redhat.com>
AuthorDate: Mon Nov 16 12:17:53 2015 -0500
Commit:     Tina Fitzgerald <tfitzger@redhat.com>
CommitDate: Tue Jan 19 13:03:17 2016 -0500

    Removed get_domain_details and related code.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1256300

 app/models/miq_provision/automate.rb               | 32 ------------------
 app/models/miq_provision_virt_workflow.rb          | 38 +---------------------
 .../service_models/miq_ae_service_miq_provision.rb |  4 ---
 .../Provisioning/Information.class/__class__.yaml  | 20 ------------
 .../Provisioning/Information.class/default.yaml    |  2 --
 .../miq_automation_engine/miq_ae_engine_spec.rb    |  1 -
 .../miq_automation_engine/miq_ae_provision_spec.rb | 17 ----------
 spec/lib/miq_automation_engine/miq_ae_uri_spec.rb  |  1 -
 spec/models/miq_provision/automate_spec.rb         | 38 ----------------------
 9 files changed, 1 insertion(+), 152 deletions(-)
 delete mode 100644 spec/models/miq_provision/automate_spec.rb
Comment 6 Tina Fitzgerald 2016-01-27 14:29:14 EST
https://github.com/ManageIQ/manageiq/pull/5460
Comment 7 Ramesh A 2016-04-22 09:40:22 EDT
Good to go.  Verified and working fine in 5.6.0.4-beta2.3.20160421172650_719e256
Comment 9 errata-xmlrpc 2016-06-29 10:59:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.