This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1256309 - Editing Host via Webadmin Hangs
Editing Host via Webadmin Hangs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
x86_64 Unspecified
unspecified Severity high
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Oved Ourfali
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-24 06:55 EDT by Kevin Alon Goldblatt
Modified: 2016-04-19 21:32 EDT (History)
12 users (show)

See Also:
Fixed In Version: 3.6.0-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-19 21:32:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen-cast: Edit Host's Cluster (3.15 MB, application/ogg)
2015-08-25 08:18 EDT, Einav Cohen
no flags Details

  None (edit)
Description Kevin Alon Goldblatt 2015-08-24 06:55:01 EDT
Description of problem:
When editing a Host and changing the Cluster, then saving leaves the Edit window Hanging

Version-Release number of selected component (if applicable):
rhevm-3.6.0-0.11.master.el6.noarch - running on Rhel6.7
vdsm-4.17.2-1.el7ev.noarch - running on Rhel7.2

How reproducible:
100%


Steps to Reproduce:
1. Via the Webadmin -> Hosts -> Edit host
2. Change the Cluster to another cluster
3. Press OK >>>>> The operation hangs indefenitely and does not complete
4. No Task is reported in the Engine.log

Actual results:
The Edit host operation hangs and does not complete


Expected results:
The edit host operation should be successfull

Additional info:
NO ENTRIES ARE REPORTED IN THE LOGS
Comment 1 Tal Nisan 2015-08-24 07:18:59 EDT
This issue is not a related to storage in any way, probably ux
Comment 2 Einav Cohen 2015-08-25 08:18:12 EDT
Created attachment 1066832 [details]
screen-cast: Edit Host's Cluster
Comment 3 Einav Cohen 2015-08-25 08:23:28 EDT
Can't reproduce on latest master - see attachment 1066832 [details] - I can successfully change the Host's cluster to be another cluster in another data-center, or another cluster in the same data-center. 
I assume that this is not reproducible on latest 3.6 as well (could be a duplicate - not sure). 
I'm also not sure if having a fencing-agent defined makes any difference. 

@Kevin: You have tested rhevm-3.6.0-0.11 (3.6.0-9) - can you please re-test in rhevm-3.6.0-0.12 (3.6.0-10)? can you also please test editing a Host with and without a fencing agent defined, and see if it makes any difference?

thanks.
Comment 4 Pavel Stehlik 2015-08-26 07:50:59 EDT
The issue was caused by JS exception (I saw it on different enviroment as well).

It works on:
rhevm-webadmin-portal-3.6.0-0.12.master.el6.noarch
Comment 5 Einav Cohen 2015-08-26 11:22:50 EDT
(In reply to Pavel Stehlik from comment #4)
> The issue was caused by JS exception (I saw it on different enviroment as
> well).
> 
> It works on:
> rhevm-webadmin-portal-3.6.0-0.12.master.el6.noarch

thanks, Pavel.

Note You need to log in before you can comment on or make changes to this bug.