Bug 1256318 - Removing GTP partition table doesn't remove PMBR
Removing GTP partition table doesn't remove PMBR
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: blivet-maint-list@redhat.com
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-24 07:09 EDT by Vojtech Trefny
Modified: 2016-07-27 13:45 EDT (History)
4 users (show)

See Also:
Fixed In Version: python-blivet-2.0.0-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 13:45:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vojtech Trefny 2015-08-24 07:09:52 EDT
Running ActionDestroyFormat on disk with a GPT disklabel doesn't destroy the PMBR record.

Result of this is that blivet see the disk as empty (without disklabel) but can't format it to btrfs (or ext4 or any non-disklabel format type) because we call the mkfs command without using "--force" option.

We are using libparted method "ped_disk_clobber" that doesn't destroy the PMBR record.
Comment 1 David Lehman 2015-08-24 10:21:56 EDT
I had to fix this on uevents-branch. I can make a pull request to bring that to master.
Comment 3 Fedora Admin XMLRPC Client 2015-09-28 16:27:06 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Note You need to log in before you can comment on or make changes to this bug.