Bug 1256320 - php: Use After Free Vulnerability in unserialize() with SplDoublyLinkedList
php: Use After Free Vulnerability in unserialize() with SplDoublyLinkedList
Status: CLOSED DUPLICATE of bug 1256290
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20150806,repor...
: Security
Depends On:
Blocks: 1252058
  Show dependency treegraph
 
Reported: 2015-08-24 07:10 EDT by Vasyl Kaigorodov
Modified: 2016-11-08 11:17 EST (History)
15 users (show)

See Also:
Fixed In Version: PHP 5.6.12, PHP 5.5.28, PHP 5.4.44
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-09 04:59:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vasyl Kaigorodov 2015-08-24 07:10:43 EDT
Use-after-free vulnerability that can potentially lead to remote code execution was reported in PHP:
https://bugs.php.net/bug.php?id=70169

CVE request: https://seclists.org/oss-sec/2015/q3/393
Upstream fix: http://git.php.net/?p=php-src.git;a=commit;h=863bf294feb9ad425eadb94f288bc7f18673089d
Comment 1 Adam Mariš 2015-09-09 04:59:41 EDT

*** This bug has been marked as a duplicate of bug 1256290 ***

Note You need to log in before you can comment on or make changes to this bug.