Bug 1256352 - gluster-nfs : contents of export file is not updated correctly in its context
gluster-nfs : contents of export file is not updated correctly in its context
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
mainline
All NetBSD
medium Severity medium
: ---
: ---
Assigned To: Jiffin
: Triaged
Depends On:
Blocks: 1258717
  Show dependency treegraph
 
Reported: 2015-08-24 08:08 EDT by Jiffin
Modified: 2016-06-16 09:33 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1258717 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:33:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiffin 2015-08-24 08:08:58 EDT
Description of problem:

The following tests(50,51) in mount-nfs-auth.t were failing spuriously for NETBSD machines. In those tests, nfs client is only allowed for reads. Here even though export file is updated correctly but it is not reflected in nfs-server context. So write will be allowed for those clients.

Version-Release number of selected component (if applicable):
mainline

How reproducible:
10% when mount-nfs-auth.t executed in NETBSD machine.(Spurious failure)

Steps to Reproduce:
Run mount-nfs-auth.t in infinite loop . The test will fail at 50,51 cases(which checks for read-only client) at some point.

Actual results:
Servers allow write operation 

Expected results:
Server should not allow write operation.

Additional info:

It seems to be when contents of export file are updated , then _mnt3_auth_param_refresh_thread() should call _mnt3_has_file_changed(). But it is not happening for those above mentioned tests which can be understand from nfs-server log.

The following logs were missing after updating the export file :

[MSGID: 112147] [mount3.c:3720:_mnt3_auth_param_refresh_thread] 0-nfs-mount: File /autobuild/install/var/db/glusterd/nfs/exports changed, updating exports,

[MSGID: 112151] [mount3.c:3752:_mnt3_auth_param_refresh_thread] 0-nfs-mount: Purging auth cache
Comment 1 Anand Avati 2015-08-31 01:34:00 EDT
REVIEW: http://review.gluster.org/12006 (tests : workaround for the spourious failure in mount-nfs-auth.t) posted (#2) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 2 Anand Avati 2015-08-31 03:28:46 EDT
REVIEW: http://review.gluster.org/12006 (tests : workaround for the spurious failure in mount-nfs-auth.t) posted (#3) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 3 Anand Avati 2015-08-31 15:00:19 EDT
COMMIT: http://review.gluster.org/12006 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 9f52d22690b3b0aac0a736eb15fe649fde6286b5
Author: Jiffin Tony Thottan <jthottan@redhat.com>
Date:   Mon Aug 24 18:01:19 2015 +0530

    tests : workaround for the spurious failure in mount-nfs-auth.t
    
    Change-Id: I459a0c60743291a2e164a5e0a76a7e2577afdae0
    BUG: 1256352
    Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    Reviewed-on: http://review.gluster.org/12006
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 4 Niels de Vos 2016-06-16 09:33:12 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.