Bug 1256372 - Installation via dnf `install scrren ' is incorrect
Installation via dnf `install scrren ' is incorrect
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: screen (Show other bugs)
24
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Josef Ridky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-24 08:35 EDT by Joseph Pesco
Modified: 2016-08-04 07:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-04 07:25:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
installation screen dump from installation and an attempt to use screen (3.30 KB, text/plain)
2015-08-24 08:35 EDT, Joseph Pesco
no flags Details
Result of running dnf history 8/31/2015 5:54 am pdt f22 on Acer (3.59 KB, text/plain)
2015-08-31 08:55 EDT, Joseph Pesco
no flags Details

  None (edit)
Description Joseph Pesco 2015-08-24 08:35:20 EDT
Created attachment 1066353 [details]
installation screen dump from installation and an attempt to use screen

Description of problem:

During installation of screen with dnf:

groupadd: cannot open /etc/group





Version-Release number of selected component (if applicable):
f22 x86_64 kde desktoop 

How reproducible:
very

Steps to Reproduce:
1. dnf install screen
2. type screen on command line
3.

Actual results:
When attempting to run screen:
 
[root@localhost ~]# screen 
Directory '/var/run/screen' must have mode 777.
[root@localhost ~]# 

or, from a normal user account:
[condor@localhost ~]$ screen
Cannot make directory '/var/run/screen': Permission denied
[condor@localhost ~]$ 


Expected results:
screen starts as per usaual

Additional info:
See attachement
Comment 1 Petr Hracek 2015-08-31 08:00:31 EDT
I guess that this is related to groupadd component.
Did you do anything with /etc/group?
What are permissions of the file?
Comment 2 Joseph Pesco 2015-08-31 08:55:04 EDT
Created attachment 1068638 [details]
Result of running dnf history 8/31/2015 5:54 am pdt f22 on Acer
Comment 3 Petr Hracek 2015-12-21 04:18:24 EST
I guess, it is relevant to RPM.
Did you erase directory /var/run/screen?

I could not image why does not exist.

Is the problem reproducible?
Comment 4 Jan Kurik 2016-02-24 10:42:06 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Fedora Admin XMLRPC Client 2016-07-11 06:24:58 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Josef Ridky 2016-07-21 09:09:29 EDT
Unfortunately at Fedora 24 I am not able to reproduce this bug. Everything is fine here. Could you please inform me, if is this bug still actual for you? Otherwise, please close this bug.
Comment 7 Joseph Pesco 2016-08-04 07:25:09 EDT
I've only seen this happen once since the initial bug report.  I removed the package and reinstalled it.  Thanks much for the feedback.

Note You need to log in before you can comment on or make changes to this bug.