Bug 1256397 - The Subscription Manager Addon spoke should have the helpFile attribute set
The Subscription Manager Addon spoke should have the helpFile attribute set
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.2
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: candlepin-bugs
Sean Toner
:
Depends On:
Blocks: 1260071
  Show dependency treegraph
 
Reported: 2015-08-24 09:17 EDT by Martin Kolman
Modified: 2015-11-19 06:50 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 06:50:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
still no help information (17.63 KB, image/png)
2015-09-29 10:59 EDT, Sean Toner
no flags Details

  None (edit)
Description Martin Kolman 2015-08-24 09:17:42 EDT
Description of problem:
The Subscription Manager Addon spoke should have the helpFile attribute set so that the Anaconda built-in help system can show content for it. As with other spokes, hubs and addons (Kdump addon and in the future the OSCAP addon) the content is provided by the Installation Guide, so only change needed from the Subscription Manager Addon is setting the helpFile for its spoke.

How reproducible:
always

Steps to Reproduce:
1. check Subscription Manager Addon source code

Actual results:
The RHSMSpoke class has no helpFile attribute set.

Expected results:
The RHSMSpoke class has the helpFile attribute set.

Additional info:
A pull requests fixing this issue has been sent:
https://github.com/candlepin/subscription-manager/pull/1275
Comment 2 Adrian Likins 2015-09-08 12:41:46 EDT
commit https://github.com/candlepin/subscription-manager/commit/70a1957442e76e913a294d825cac85cf5dffea7d

commit 70a1957442e76e913a294d825cac85cf5dffea7d
Author: Martin Kolman <martin.kolman@gmail.com>
Date:   Mon Aug 24 15:02:49 2015 +0200

    Set help file name for the Subscription Manager spoke
    
    Set help file name for the Subscription Manager spoke so that the Anaconda build in help system can show help cont
Comment 4 Sean Toner 2015-09-29 10:37:41 EDT
Both the helpFile
Comment 5 Sean Toner 2015-09-29 10:59:17 EDT
Oops sent the wrong BZ :)  

I verified that the Help menu still does not actually provide a help menu with information for initial-setup-addon, and it appears that the helpFile attribute is not actually set until version 1.16.3-1 according to the commit in Comment #2 (which explains why I was unable to find these changes).

The latest build in brew is subscription-manager-gui-1.15.9-12.el7.x86_64 so this change
Comment 6 Sean Toner 2015-09-29 10:59 EDT
Created attachment 1078405 [details]
still no help information
Comment 7 Chris Snyder 2015-09-30 12:16:13 EDT
Please retest with snap 4
Comment 8 Sean Toner 2015-10-01 11:51:46 EDT
The helpFile = "SubscriptionManagerSpoke.xml" was actually in a different location than I was originally looking in:


root@rh72-stoner-snap4 com_redhat_subscription_manager]# grep -Hrni helpFile
gui/spokes/rhsm_gui.py:55:    helpFile = "SubscriptionManagerSpoke.xml"
Comment 9 errata-xmlrpc 2015-11-19 06:50:50 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2122.html

Note You need to log in before you can comment on or make changes to this bug.