Bug 1256405 - virt-builder created Fedora 22 32bit disk image cannot be updated
virt-builder created Fedora 22 32bit disk image cannot be updated
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libguestfs (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-24 09:41 EDT by Jan Sedlák
Modified: 2015-11-08 04:49 EST (History)
5 users (show)

See Also:
Fixed In Version: libguestfs-1.30.2-1.fc23 libguestfs-1.30.4-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-08 04:49:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
run output (523 bytes, text/plain)
2015-08-24 09:44 EDT, Jan Sedlák
no flags Details

  None (edit)
Description Jan Sedlák 2015-08-24 09:41:28 EDT
Description of problem:
When creating F22 32bit disk image with --update, it fails with:

virt-builder fedora-22 -o disk_f22_minimal_32bit.img --update --selinux-relabel --root-password password:weakpassword
...
Error: Transaction check error:
  file /usr/share/man/man5/cert8.db.5.gz from install of nss-3.19.3-1.0.fc22.x86_64 conflicts with file from package nss-3.18.0-1.fc22.i686
  file /usr/share/man/man5/cert9.db.5.gz from install of nss-3.19.3-1.0.fc22.x86_64 conflicts with file from package nss-3.18.0-1.fc22.i686
  file /usr/share/man/man5/key3.db.5.gz from install of nss-3.19.3-1.0.fc22.x86_64 conflicts with file from package nss-3.18.0-1.fc22.i686
  file /usr/share/man/man5/key4.db.5.gz from install of nss-3.19.3-1.0.fc22.x86_64 conflicts with file from package nss-3.18.0-1.fc22.i686
  file /usr/share/man/man5/pkcs11.txt.5.gz from install of nss-3.19.3-1.0.fc22.x86_64 conflicts with file from package nss-3.18.0-1.fc22.i686
  file /usr/share/man/man5/secmod.db.5.gz from install of nss-3.19.3-1.0.fc22.x86_64 conflicts with file from package nss-3.18.0-1.fc22.i686
  file /usr/share/man/man1/trust.1.gz from install of p11-kit-0.23.1-2.fc22.x86_64 conflicts with file from package p11-kit-0.23.1-1.fc22.i686
  file /usr/share/man/man5/pkcs11.conf.5.gz from install of p11-kit-0.23.1-2.fc22.x86_64 conflicts with file from package p11-kit-0.23.1-1.fc22.i686
  file /usr/share/man/man8/p11-kit.8.gz from install of p11-kit-0.23.1-2.fc22.x86_64 conflicts with file from package p11-kit-0.23.1-1.fc22.i686

It works with 64bit image.

Version-Release number of selected component (if applicable):
virt-builder 1.30.0fedora=22,release=1.fc22,libvirt
Comment 1 Jan Sedlák 2015-08-24 09:44:45 EDT
Created attachment 1066397 [details]
run output
Comment 2 Richard W.M. Jones 2015-08-24 11:53:33 EDT
I saw this a few weeks ago (and I'm fairly sure it's a dupe of
another bug, but I can't find that right now).

The cause of it is that dnf examines the processor architecture
and thus thinks it is running on x86_64 and so tries to install
x86_64 packages.

There is probably some sort of conf setting / flag we should be
passing to dnf to tell it to install basearch=i386 packages in
this case.
Comment 3 Richard W.M. Jones 2015-08-24 11:54:14 EDT
If you can determine what flag to pass to dnf, then the workaround
is simple enough.  Replace --update with

  --run-command "dnf -y --your-flag-here update"
Comment 4 Jan Sedlák 2015-08-25 07:44:48 EDT
Solution is to run "setarch i686 dnf -y update".
Comment 5 Richard W.M. Jones 2015-08-27 12:32:53 EDT
Patch posted:
https://www.redhat.com/archives/libguestfs/2015-August/msg00140.html
Comment 6 Richard W.M. Jones 2015-08-27 14:09:01 EDT
v2 patch:
https://www.redhat.com/archives/libguestfs/2015-August/msg00148.html
Comment 7 Richard W.M. Jones 2015-08-28 17:53:40 EDT
This is upstream in commit d875346ad441d4762455ea1b41d57ad6174d9b63
libguestfs >= 1.31.3.

I will move this bug back to F22 so it can be fixed on the 1.30 branch.
Comment 8 Fedora Update System 2015-08-29 16:09:08 EDT
libguestfs-1.30.1-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14565
Comment 9 Fedora Update System 2015-08-29 18:35:03 EDT
libguestfs-1.30.1-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14569
Comment 10 Fedora Update System 2015-09-01 05:58:44 EDT
libguestfs-1.30.1-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update libguestfs'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14565
Comment 11 Fedora Update System 2015-09-01 06:05:03 EDT
libguestfs-1.30.1-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update libguestfs'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14569
Comment 12 Fedora Update System 2015-09-08 17:44:58 EDT
libguestfs-1.30.2-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15401
Comment 13 Fedora Update System 2015-09-09 02:56:28 EDT
libguestfs-1.30.2-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15420
Comment 14 Fedora Update System 2015-09-09 22:07:48 EDT
libguestfs-1.30.2-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update libguestfs'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15401
Comment 15 Fedora Update System 2015-09-10 01:51:49 EDT
libguestfs-1.30.2-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update libguestfs'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15420
Comment 16 Fedora Update System 2015-10-07 07:01:58 EDT
libguestfs-1.30.3-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-cdd7fcfc3c
Comment 17 Fedora Update System 2015-10-07 12:25:49 EDT
libguestfs-1.30.3-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update libguestfs'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-cdd7fcfc3c
Comment 18 Fedora Update System 2015-10-07 12:37:07 EDT
libguestfs-1.30.2-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2015-10-26 13:31:22 EDT
libguestfs-1.30.4-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-f7b0c57297
Comment 20 Fedora Update System 2015-10-28 16:25:11 EDT
libguestfs-1.30.4-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update libguestfs'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-f7b0c57297
Comment 21 Fedora Update System 2015-11-08 04:49:18 EST
libguestfs-1.30.4-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.