Bug 1256425 - [abrt] yumex-dnf: widgets.py:307:_is_fedora_pkg:AttributeError: 'NoneType' object has no attribute 'repository'
[abrt] yumex-dnf: widgets.py:307:_is_fedora_pkg:AttributeError: 'NoneType' ob...
Status: CLOSED DUPLICATE of bug 1253630
Product: Fedora
Classification: Fedora
Component: yumex-dnf (Show other bugs)
22
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:2885e655a104a4d4ecdcdc5594f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-24 10:32 EDT by Stefan Gies
Modified: 2015-10-06 05:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-06 05:15:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (951 bytes, text/plain)
2015-08-24 10:32 EDT, Stefan Gies
no flags Details
File: environ (1.31 KB, text/plain)
2015-08-24 10:32 EDT, Stefan Gies
no flags Details

  None (edit)
Description Stefan Gies 2015-08-24 10:32:06 EDT
Version-Release number of selected component:
yumex-dnf-4.1.2-1.fc22

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python3 -tt /usr/bin/yumex-dnf
executable:     /usr/bin/yumex-dnf
kernel:         4.1.5-200.fc22.i686
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
widgets.py:307:_is_fedora_pkg:AttributeError: 'NoneType' object has no attribute 'repository'

Traceback (most recent call last):
  File "/usr/lib/python3.4/site-packages/yumex/__init__.py", line 701, in on_pkg_view_selection_changed
    self.info.set_package(pkg)
  File "/usr/lib/python3.4/site-packages/yumex/gui/widgets.py", line 258, in set_package
    self.update()
  File "/usr/lib/python3.4/site-packages/yumex/gui/widgets.py", line 268, in update
    self._show_description()
  File "/usr/lib/python3.4/site-packages/yumex/gui/widgets.py", line 324, in _show_description
    if self._is_fedora_pkg():
  File "/usr/lib/python3.4/site-packages/yumex/gui/widgets.py", line 307, in _is_fedora_pkg
    if self.current_package.repository in const.FEDORA_REPOS:
AttributeError: 'NoneType' object has no attribute 'repository'

Local variables in innermost frame:
self: <PackageInfo object at 0xb47ebf04 (yumex+gui+widgets+PackageInfo at 0x9b307c0)>

Potential duplicate: bug 1253630
Comment 1 Stefan Gies 2015-08-24 10:32:09 EDT
Created attachment 1066414 [details]
File: backtrace
Comment 2 Stefan Gies 2015-08-24 10:32:10 EDT
Created attachment 1066415 [details]
File: environ
Comment 3 Tim Lauridsen 2015-10-06 05:15:10 EDT

*** This bug has been marked as a duplicate of bug 1253630 ***

Note You need to log in before you can comment on or make changes to this bug.