Bug 1256442 - clicking on links in Terminal results in wrong browser being used
clicking on links in Terminal results in wrong browser being used
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xfce4-session (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-24 11:04 EDT by Dennis Gilmore
Modified: 2015-09-25 03:58 EDT (History)
2 users (show)

See Also:
Fixed In Version: xfce4-session-4.12.1-6.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-25 03:58:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2015-08-24 11:04:48 EDT
Description of problem:
my preferred browser is set to firefox. If i click on a link in terminal it opens in midori

Version-Release number of selected component (if applicable):
xfce4-session-4.12.1-5.fc23.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Kevin Fenzi 2015-08-30 14:38:14 EDT
Downgrading to xfce4-session-4.12.1-4.fc23.x86_64 causes it to work as expected?
Comment 2 Dennis Gilmore 2015-08-30 19:19:33 EDT
yes it does
Comment 3 Kevin Fenzi 2015-09-12 17:36:10 EDT
ok. I dug around some more on this today. 

There's two things here: 

1. We need to change the xfce-mimeapps.list to use exo-web-browser.desktop instead of hard coding midori. This would allow us to call whatever preferred browser is set in exo-preferred-applications. 

2. Even after doing the above, I had to move aside an old ~/.config/mimeapps.list because it had some x-scheme-handler/http*= that pointed to the wrong browser. 

I'm going to push a xfce4-session update that does point 1 above.
Comment 4 Fedora Update System 2015-09-12 18:09:30 EDT
xfce4-session-4.12.1-6.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15703
Comment 5 Fedora Update System 2015-09-13 14:20:09 EDT
xfce4-session-4.12.1-6.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update xfce4-session'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15703
Comment 6 Fedora Update System 2015-09-25 03:58:17 EDT
xfce4-session-4.12.1-6.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.