Bug 1256444 - Errata TPS rpm Upgrade and Install test fails
Errata TPS rpm Upgrade and Install test fails
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pam_pkcs11 (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bob Relyea
Asha Akkiangady
:
: 1256833 (view as bug list)
Depends On:
Blocks: 1186677
  Show dependency treegraph
 
Reported: 2015-08-24 11:12 EDT by Asha Akkiangady
Modified: 2015-11-19 08:01 EST (History)
2 users (show)

See Also:
Fixed In Version: pam_pkcs11-0.6.2-22.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 08:01:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Asha Akkiangady 2015-08-24 11:12:42 EDT
Description of problem:
Errata TPS rpm Upgrade and Install test fails.

Version-Release number of selected component (if applicable):
pam_pkcs11-0.6.2-21.el7

How reproducible:


Steps to Reproduce:
Errata link: https://errata.devel.redhat.com/advisory/21066

UpgradeTest:
begin at 07/21/2015 17:01:51 on x86-64-7w-v1.ss.eng.bos.redhat.com
PkgState: oldCnt 3 ; oldInstCnt 3 ; newCnt 3 ; newInstCnt 0 ; none = 0 ; dropCnt 0 ; addCnt 0 ; strayCnt 0
3 of 3 OLD, 0 of 3 NEW, and 0 STRAY packages are installed
doRpmCommand: rpm -U /mnt/redhat/brewroot/packages/pam_pkcs11/0.6.2/21.el7/x86_64/pam_pkcs11-0.6.2-21.el7.x86_64.rpm /mnt/redhat/brewroot/packages/pam_pkcs11/0.6.2/21.el7/i686/pam_pkcs11-0.6.2-21.el7.i686.rpm /mnt/redhat/brewroot/packages/pam_pkcs11/0.6.2/21.el7/x86_64/pam_pkcs11-debuginfo-0.6.2-21.el7.x86_64.rpm
doRpmCommand-result (1536): file /usr/share/doc/pam_pkcs11-0.6.2/pam_pkcs11.html conflicts between attempted installs of pam_pkcs11-0.6.2-21.el7.i686 and pam_pkcs11-0.6.2-21.el7.x86_64
PkgState: oldCnt 3 ; oldInstCnt 3 ; newCnt 3 ; newInstCnt 0 ; none = 0 ; dropCnt 0 ; addCnt 0 ; strayCnt 0
3 of 3 OLD, 0 of 3 NEW, and 0 STRAY packages are installed
Upgrade test FAILED
Output from RPM Command:
file /usr/share/doc/pam_pkcs11-0.6.2/pam_pkcs11.html conflicts between attempted installs of pam_pkcs11-0.6.2-21.el7.i686 and pam_pkcs11-0.6.2-21.el7.x86_64
Old packages: /mnt/redhat/brewroot/packages/pam_pkcs11/0.6.2/18.el7/data/signed/fd431d51/x86_64/pam_pkcs11-0.6.2-18.el7.x86_64.rpm /mnt/redhat/brewroot/packages/pam_pkcs11/0.6.2/18.el7/data/signed/fd431d51/i686/pam_pkcs11-0.6.2-18.el7.i686.rpm /mnt/redhat/brewroot/packages/pam_pkcs11/0.6.2/18.el7/data/signed/fd431d51/x86_64/pam_pkcs11-debuginfo-0.6.2-18.el7.x86_64.rpm
New packages: /mnt/redhat/brewroot/packages/pam_pkcs11/0.6.2/21.el7/x86_64/pam_pkcs11-0.6.2-21.el7.x86_64.rpm /mnt/redhat/brewroot/packages/pam_pkcs11/0.6.2/21.el7/i686/pam_pkcs11-0.6.2-21.el7.i686.rpm /mnt/redhat/brewroot/packages/pam_pkcs11/0.6.2/21.el7/x86_64/pam_pkcs11-debuginfo-0.6.2-21.el7.x86_64.rpm
Packages on system after upgrade attempt - old -
pam_pkcs11-0.6.2-18.el7.i686
pam_pkcs11-0.6.2-18.el7.x86_64
pam_pkcs11-debuginfo-0.6.2-18.el7.x86_64
end test at Tue Jul 21 17:01:52 EDT 2015 on x86-64-7w-v1.ss.eng.bos.redhat.com
TPSRESULT: UpgradeTest Returning: FAIL


InstallTest:
begin at 07/21/2015 17:01:54 on x86-64-7w-v1.ss.eng.bos.redhat.com
PkgState: oldCnt 3 ; oldInstCnt 0 ; newCnt 3 ; newInstCnt 0 ; none = 3 ; dropCnt 0 ; addCnt 0 ; strayCnt 0
0 of 3 OLD, 0 of 3 NEW, and 0 STRAY packages are installed
doRpmCommand: rpm -i /mnt/redhat/brewroot/packages/pam_pkcs11/0.6.2/21.el7/x86_64/pam_pkcs11-0.6.2-21.el7.x86_64.rpm /mnt/redhat/brewroot/packages/pam_pkcs11/0.6.2/21.el7/i686/pam_pkcs11-0.6.2-21.el7.i686.rpm /mnt/redhat/brewroot/packages/pam_pkcs11/0.6.2/21.el7/x86_64/pam_pkcs11-debuginfo-0.6.2-21.el7.x86_64.rpm
doRpmCommand-result (768): file /usr/share/doc/pam_pkcs11-0.6.2/pam_pkcs11.html conflicts between attempted installs of pam_pkcs11-0.6.2-21.el7.i686 and pam_pkcs11-0.6.2-21.el7.x86_64
PkgState: oldCnt 3 ; oldInstCnt 0 ; newCnt 3 ; newInstCnt 0 ; none = 3 ; dropCnt 0 ; addCnt 0 ; strayCnt 0
0 of 3 OLD, 0 of 3 NEW, and 0 STRAY packages are installed
Install test FAILED
Output from RPM Command:
file /usr/share/doc/pam_pkcs11-0.6.2/pam_pkcs11.html conflicts between attempted installs of pam_pkcs11-0.6.2-21.el7.i686 and pam_pkcs11-0.6.2-21.el7.x86_64
Old packages: /mnt/redhat/brewroot/packages/pam_pkcs11/0.6.2/18.el7/data/signed/fd431d51/x86_64/pam_pkcs11-0.6.2-18.el7.x86_64.rpm /mnt/redhat/brewroot/packages/pam_pkcs11/0.6.2/18.el7/data/signed/fd431d51/i686/pam_pkcs11-0.6.2-18.el7.i686.rpm /mnt/redhat/brewroot/packages/pam_pkcs11/0.6.2/18.el7/data/signed/fd431d51/x86_64/pam_pkcs11-debuginfo-0.6.2-18.el7.x86_64.rpm
New packages: /mnt/redhat/brewroot/packages/pam_pkcs11/0.6.2/21.el7/x86_64/pam_pkcs11-0.6.2-21.el7.x86_64.rpm /mnt/redhat/brewroot/packages/pam_pkcs11/0.6.2/21.el7/i686/pam_pkcs11-0.6.2-21.el7.i686.rpm /mnt/redhat/brewroot/packages/pam_pkcs11/0.6.2/21.el7/x86_64/pam_pkcs11-debuginfo-0.6.2-21.el7.x86_64.rpm
Packages on system after install attempt - none -
end test at Tue Jul 21 17:01:55 EDT 2015 on x86-64-7w-v1.ss.eng.bos.redhat.com
TPSRESULT: InstallTest Returning: FAIL


Same failure observed on X86_64  RHEL 7 workstation, ppc64 RHEL 7 server, x86_64 RHEL 7 server and x86_64 RHEL 7 Client.

Errata TPS tests Results for x86_64 RHEL 7 server :: http://nest.test.redhat.com/mnt/qa/scratch/x86-64-7s-m1/2015:21066/tps/tps.html

Actual results:
Upgrade and Install TPS test fails.

Expected results:
Upgrade and Install should be successful.

Additional info:
Comment 2 Bob Relyea 2015-08-25 14:07:46 EDT
The problem seems to be caused by installing 64 bit and 32 bit at the same time.
Comment 3 Bob Relyea 2015-08-25 15:06:59 EDT
fixed in pam_pkcs11-0.6.2-22.el7
Comment 5 Bob Relyea 2015-09-08 14:06:24 EDT
*** Bug 1256833 has been marked as a duplicate of this bug. ***
Comment 6 Roshni 2015-09-08 15:07:31 EDT
[root@apm-mustang-ev3-15 tps]# rpm -qi pam_pkcs11
Name        : pam_pkcs11
Version     : 0.6.2
Release     : 23.el7
Architecture: aarch64
Install Date: Tue 08 Sep 2015 02:49:03 PM EDT
Group       : System Environment/Base
Size        : 1395150
License     : LGPLv2+
Signature   : (none)
Source RPM  : pam_pkcs11-0.6.2-23.el7.src.rpm
Build Date  : Mon 31 Aug 2015 08:46:07 PM EDT
Build Host  : arm64-005.build.eng.bos.redhat.com
Relocations : (not relocatable)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Vendor      : Red Hat, Inc.
URL         : http://www.opensc-project.org/pam_pkcs11
Summary     : PKCS #11/NSS PAM login module

All TPS tests passed for the errata with this build
Comment 7 errata-xmlrpc 2015-11-19 08:01:15 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2415.html

Note You need to log in before you can comment on or make changes to this bug.