Bug 1256445 - Cannot fedpkg mockbuild for f23 from RHEL/CentOS 6 or 7 due to dnf requirement
Cannot fedpkg mockbuild for f23 from RHEL/CentOS 6 or 7 due to dnf requirement
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
23
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-24 11:13 EDT by Erik Johnson
Modified: 2015-08-24 18:06 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-24 16:52:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik Johnson 2015-08-24 11:13:37 EDT
Description of problem:

Running a fedpkg mockbuild from RHEL/CentOS 6 or 7 fails because dnf is not available. This is due to the following line, present both in the f23 and rawhide mock configs as of mock-1.2.12-1.el6.noarch:

config_opts['package_manager'] = 'dnf'


Version-Release number of selected component (if applicable):

mock-1.2.12-1.el6.noarch


How reproducible:

100% of the time on RHEL/CentOS 6 and 7


Steps to Reproduce:
1. Attempt to run "fedpkg mockbuild" while checked out to the f23 or master branch in a fedpkg clone.


Actual results:

mock build fails because dnf is not available


Expected results:

mock should use yum for these builds
Comment 2 Erik Johnson 2015-08-24 18:06:46 EDT
I've seen it, and still considered it to be a bug. You shouldn't have to mess with the config files deployed by mock to use it.

But, given that it doesn't seem you agree, and I don't really care enough to press the issue, I'm not going go pursue it any further.

Note You need to log in before you can comment on or make changes to this bug.