Bug 1256467 - hosted-engine-setup fails acquiring CA.crt with a 404 error
hosted-engine-setup fails acquiring CA.crt with a 404 error
Status: CLOSED CURRENTRELEASE
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Plugins.PKI (Show other bugs)
2.0.0
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-3.6.1
: 1.3.1
Assigned To: Simone Tiraboschi
Nikolai Sednev
integration
: Automation, Triaged, ZStream
Depends On:
Blocks: 1284979
  Show dependency treegraph
 
Reported: 2015-08-24 12:19 EDT by Simone Tiraboschi
Modified: 2015-12-16 07:18 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: hosted-engine setup was trying to fetch the CA cert from http://{fqdn}/ca.crt but since 3.6 that certificate is available only from the pki-resource servlet. Consequence: A 404 error Fix: Getting and validating the CA cert from the pki-resource servlet
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 07:18:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: blocker+
rule-engine: planning_ack+
sbonazzo: devel_ack+
istein: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45270 master MERGED pki: acquiring certs from pki-resource servlet Never
oVirt gerrit 47336 ovirt-hosted-engine-setup-1.3 MERGED pki: acquiring certs from pki-resource servlet Never

  None (edit)
Description Simone Tiraboschi 2015-08-24 12:19:03 EDT
Description of problem:
hosted-engine-setup fails acquiring CA.crt:
 [ INFO  ] Engine replied: DB Up!Welcome to Health Status!
 [ ERROR ] Failed to execute stage 'Closing up': HTTP Error 404: Not Found
 [ INFO  ] Stage: Clean up
In the past the cert was available as
http://{fqdn}/ca.crt
but now the engine responds with a 404 Not found.

Moving to pki-resource servlet


Version-Release number of selected component (if applicable):
3.6 beta 2

How reproducible:
100%

Steps to Reproduce:
1. lauch hosted-engine --deploy
2.
3.

Actual results:
 [ ERROR ] Failed to execute stage 'Closing up': HTTP Error 404: Not Found

Expected results:
it deploys

Additional info:
Comment 1 Simone Tiraboschi 2015-09-01 11:47:49 EDT
It doesn't reproduce on 3.6 but only in master
Comment 2 Red Hat Bugzilla Rules Engine 2015-10-19 06:53:49 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 3 Red Hat Bugzilla Rules Engine 2015-10-22 10:17:10 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 4 Nikolai Sednev 2015-11-25 02:48:10 EST
Works for me on these components:
ovirt-vmconsole-host-1.0.1-0.0.master.20151105234454.git3e5d52e.el7.noarch
ovirt-release36-002-2.noarch
ovirt-engine-sdk-python-3.6.0.4-0.2.20151123.gita2f81ed.el7.centos.noarch
sanlock-3.2.4-1.el7.x86_64
ovirt-setup-lib-1.0.1-0.0.master.20151119123055.gitfa908be.el7.centos.noarch
qemu-kvm-rhev-2.3.0-31.el7_2.3.x86_64
ovirt-hosted-engine-ha-1.3.3-0.0.master.20151118145556.20151118145552.git71b535e.el7.noarch
ovirt-vmconsole-1.0.1-0.0.master.20151105234454.git3e5d52e.el7.noarch
ovirt-release36-snapshot-002-2.noarch
libvirt-client-1.2.17-13.el7.x86_64
ovirt-hosted-engine-setup-1.3.1-0.0.master.20151118143825.gitc013638.el7.centos.noarch
ovirt-host-deploy-1.4.2-0.0.master.20151122153544.gitfc808fc.el7.noarch
vdsm-4.17.10.1-0.el7ev.noarch
mom-0.5.1-2.el7.noarch
Comment 5 Sandro Bonazzola 2015-12-16 07:18:20 EST
According to verification status and target milestone this issue should be fixed in oVirt 3.6.1. Closing current release.

Note You need to log in before you can comment on or make changes to this bug.