Bug 1256474 - [abrt] trojita: Imap::Mailbox::ImapTask::log(): trojita killed by SIGSEGV
[abrt] trojita: Imap::Mailbox::ImapTask::log(): trojita killed by SIGSEGV
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: trojita (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Raphael Groner
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:42cda4c4b316750560a7faf1194...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-24 12:39 EDT by Karel Volný
Modified: 2015-12-24 19:25 EST (History)
2 users (show)

See Also:
Fixed In Version: trojita-0.5a-2.20151216gitefa30f3.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-24 19:25:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (61.76 KB, text/plain)
2015-08-24 12:39 EDT, Karel Volný
no flags Details
File: cgroup (190 bytes, text/plain)
2015-08-24 12:39 EDT, Karel Volný
no flags Details
File: core_backtrace (6.84 KB, text/plain)
2015-08-24 12:39 EDT, Karel Volný
no flags Details
File: dso_list (20.68 KB, text/plain)
2015-08-24 12:39 EDT, Karel Volný
no flags Details
File: environ (3.27 KB, text/plain)
2015-08-24 12:39 EDT, Karel Volný
no flags Details
File: limits (1.29 KB, text/plain)
2015-08-24 12:39 EDT, Karel Volný
no flags Details
File: maps (94.16 KB, text/plain)
2015-08-24 12:39 EDT, Karel Volný
no flags Details
File: mountinfo (3.16 KB, text/plain)
2015-08-24 12:39 EDT, Karel Volný
no flags Details
File: namespaces (85 bytes, text/plain)
2015-08-24 12:39 EDT, Karel Volný
no flags Details
File: open_fds (1.32 KB, text/plain)
2015-08-24 12:39 EDT, Karel Volný
no flags Details
File: proc_pid_status (1.00 KB, text/plain)
2015-08-24 12:39 EDT, Karel Volný
no flags Details
File: var_log_messages (308 bytes, text/plain)
2015-08-24 12:39 EDT, Karel Volný
no flags Details

  None (edit)
Description Karel Volný 2015-08-24 12:39:01 EDT
Version-Release number of selected component:
trojita-0.5-7.fc23

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        trojita
crash_function: Imap::Mailbox::ImapTask::log
executable:     /usr/bin/trojita
global_pid:     29883
kernel:         4.2.0-0.rc6.git0.2.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 Imap::Mailbox::ImapTask::log at /usr/src/debug/trojita-0.5/src/Imap/Tasks/ImapTask.cpp:304
 #1 Imap::Mailbox::ImapTask::_failed at /usr/src/debug/trojita-0.5/src/Imap/Tasks/ImapTask.cpp:239
 #2 Imap::Mailbox::Model::killParser at /usr/src/debug/trojita-0.5/src/Imap/Model/Model.cpp:1471
 #3 Imap::Mailbox::Model::handleSocketDisconnectedResponse at /usr/src/debug/trojita-0.5/src/Imap/Model/Model.cpp:1134
 #4 Imap::Mailbox::Model::responseReceived at /usr/src/debug/trojita-0.5/src/Imap/Model/Model.cpp:245
 #6 Imap::Mailbox::Model::qt_static_metacall at /usr/src/debug/trojita-0.5/build/moc_Model.cpp:322
 #7 QObject::event at kernel/qobject.cpp:1246
 #8 QApplicationPrivate::notify_helper at kernel/qapplication.cpp:3717
 #9 QApplication::notify at kernel/qapplication.cpp:3500
 #10 QCoreApplication::notifyInternal at kernel/qcoreapplication.cpp:965
Comment 1 Karel Volný 2015-08-24 12:39:04 EDT
Created attachment 1066513 [details]
File: backtrace
Comment 2 Karel Volný 2015-08-24 12:39:05 EDT
Created attachment 1066514 [details]
File: cgroup
Comment 3 Karel Volný 2015-08-24 12:39:06 EDT
Created attachment 1066515 [details]
File: core_backtrace
Comment 4 Karel Volný 2015-08-24 12:39:08 EDT
Created attachment 1066516 [details]
File: dso_list
Comment 5 Karel Volný 2015-08-24 12:39:09 EDT
Created attachment 1066517 [details]
File: environ
Comment 6 Karel Volný 2015-08-24 12:39:10 EDT
Created attachment 1066518 [details]
File: limits
Comment 7 Karel Volný 2015-08-24 12:39:12 EDT
Created attachment 1066519 [details]
File: maps
Comment 8 Karel Volný 2015-08-24 12:39:13 EDT
Created attachment 1066520 [details]
File: mountinfo
Comment 9 Karel Volný 2015-08-24 12:39:14 EDT
Created attachment 1066521 [details]
File: namespaces
Comment 10 Karel Volný 2015-08-24 12:39:15 EDT
Created attachment 1066522 [details]
File: open_fds
Comment 11 Karel Volný 2015-08-24 12:39:16 EDT
Created attachment 1066523 [details]
File: proc_pid_status
Comment 12 Karel Volný 2015-08-24 12:39:17 EDT
Created attachment 1066524 [details]
File: var_log_messages
Comment 13 Raphael Groner 2015-08-24 12:58:03 EDT
Hi Karel,

thanks for your report. Can you reproduce this crash, what were you doing for it? Especially as you reported against f23, I wonder if it can be duplicated in Fedora 22.
Comment 14 Karel Volný 2015-08-27 12:34:14 EDT
(In reply to Raphael Groner from comment #13)
> Can you reproduce this crash, what were you doing for it?

unfortunately not; or at least I wasn't able to figure out any sequence of actions leading to crash, and while I'm getting crashes quite often after the upgrade, it seems it hits different code each time

> Especially as you reported against f23, I wonder if it can be duplicated in
> Fedora 22.

I'd think so, so far I haven't seen anything fixed (as I hoped when updating to pre-release version) :-/
Comment 15 Karel Volný 2015-08-27 12:40:01 EDT
(In reply to Karel Volný from comment #14)
> ... after the upgrade ...

oops, I've mixed the versions

I mean that my system started to exhibit crashes after upgrade to Fedora 22

as it included 'fresh' KDE 5, I was hoping that upgrading again to F23 will bring me newer (and more mature) version with less crashes, but it did not happen
Comment 16 Raphael Groner 2015-09-16 02:04:29 EDT
As far as I can understand the provided backtrace and available source, Trojita lost network connection for any strange reason and then tried to log it and crashed. Due to the fact that it is obviously difficult to reproduce the original situation, I'll close this. Please feel free to reopen if problem still exists, then I try to poke upstream.
Comment 17 Fedora Update System 2015-12-17 05:27:21 EST
trojita-0.5a-2.20151216gitefa30f3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update trojita'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-afb9844b79
Comment 18 Fedora Update System 2015-12-24 19:25:49 EST
trojita-0.5a-2.20151216gitefa30f3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.