Bug 1256494 - Cannot view content host errata with view_content_host permission
Summary: Cannot view content host errata with view_content_host permission
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Errata Management
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Walden Raines
QA Contact: Corey Welton
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1338675 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-08-24 18:16 UTC by Walden Raines
Modified: 2019-10-10 10:06 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:18:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description Walden Raines 2015-08-24 18:16:06 UTC
Currently there is no permission that will give you access to view content host errata, you must be an administrator.

[walden@wraines-sandbox katello ((7e2c153...))]$ grep -r "katello/api/v2/system_errata" .
./lib/katello/permissions/content_host_permissions.rb:               'katello/api/v2/system_errata' => [:show],
./lib/katello/permissions/content_host_permissions.rb:               'katello/api/v2/system_errata' => [:apply],

We need to add a permission for system errata index.

h3. Steps to Reproduce

# Create a non-admin user
# Give them the view content hosts permission
# Login as that user
# Go to the content host page
# Note that you cannot view errara

Comment 1 Walden Raines 2015-08-24 18:16:07 UTC
Created from redmine issue http://projects.theforeman.org/issues/11470

Comment 2 Walden Raines 2015-08-24 18:16:09 UTC
Upstream bug assigned to walden@redhat.com

Comment 4 Walden Raines 2015-08-24 18:27:14 UTC
PR: https://github.com/Katello/katello/pull/5438

Comment 5 Bryan Kearney 2015-08-24 20:04:53 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/11470 has been closed
-------------
Walden Raines
Applied in changeset commit:katello|b8caed331164398340f5e8974aea39b7930efedd.

Comment 6 Tazim Kolhar 2015-10-27 13:23:45 UTC
*** This bug is verified in upstream.  This fix should eventually land in future downstream builds ***
Version Tested:

# rpm -qa | grep foreman
foreman-proxy-1.11.0-0.develop.201510201341git00875b3.el7.noarch
foreman-selinux-1.11.0-0.develop.201510071426git6234447.el7.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-3.el7.noarch
tfm-rubygem-foreman_docker-1.4.1-2.fm1_10.el7.noarch
foreman-libvirt-1.11.0-0.develop.201510201422git6eb234a.el7.noarch
foreman-compute-1.11.0-0.develop.201510201422git6eb234a.el7.noarch
foreman-release-scl-1-1.el7.x86_64
foreman-gce-1.11.0-0.develop.201510201422git6eb234a.el7.noarch
foreman-debug-1.11.0-0.develop.201510201422git6eb234a.el7.noarch
tfm-rubygem-foreman_gutterball-0.0.1-3.el7.noarch
hp-sl2x170zg6-01.rhts.eng.bos.redhat.com-foreman-proxy-1.0-2.noarch
tfm-rubygem-foreman_discovery-4.1.1-1.fm1_11.el7.noarch
foreman-vmware-1.11.0-0.develop.201510201422git6eb234a.el7.noarch
tfm-rubygem-foreman_hooks-0.3.9-1.el7.noarch
tfm-rubygem-foreman-tasks-0.7.6-1.fm1_10.el7.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.8-1.el7.noarch
tfm-rubygem-foreman_bootdisk-6.0.0-2.fm1_10.el7.noarch
hp-sl2x170zg6-01.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
hp-sl2x170zg6-01.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
foreman-ovirt-1.11.0-0.develop.201510201422git6eb234a.el7.noarch
foreman-1.11.0-0.develop.201510201422git6eb234a.el7.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.3-4.el7.noarch
foreman-release-1.11.0-0.develop.201510201422git6eb234a.el7.noarch
foreman-postgresql-1.11.0-0.develop.201510201422git6eb234a.el7.noarch
tfm-rubygem-hammer_cli_foreman-0.4.0-1.201510201150gitab068d9.el7.noarch

steps:
# Create a non-admin user
# Give them the view content hosts permission
# Login as that user
# Go to the content host page
# Note that you cannot view errata

Comment 9 Sean O'Keeffe 2016-07-20 09:23:23 UTC
*** Bug 1338675 has been marked as a duplicate of this bug. ***

Comment 13 errata-xmlrpc 2016-07-27 09:18:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.