Bug 1256512 - [RFE] Cinder internal tenant
[RFE] Cinder internal tenant
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: beta
: 8.0 (Liberty)
Assigned To: Eric Harney
lkuchlan
: FutureFeature
Depends On:
Blocks: 1286518
  Show dependency treegraph
 
Reported: 2015-08-24 15:40 EDT by Sean Cohen
Modified: 2016-10-03 09:54 EDT (History)
4 users (show)

See Also:
Fixed In Version: openstack-cinder-7.0.0-2.el7ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:03:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 199352 None None None Never

  None (edit)
Description Sean Cohen 2015-08-24 15:40:50 EDT
There are a few different use cases for the internal tenant. The generic use case is for any volume or snapshot object in Cinder that we do not want exposed to normal users, but would like to keep track of and have treated as normal volumes and snapshots.

There are a few features which would be able to take advantage of this:

    Image Caching - Volumes (and potentially snapshots) that are used as part of the image cache could be owned by the tenant.
    Volume Migration - Temporary volumes while migrations are taking place could be owned by the cinder-internal tenant.
    Non-Disruptive Backups - Temporary snapshots and volumes could be owned by the cinder-internal tenant.

Full spec: http://specs.openstack.org/openstack/cinder-specs/specs/liberty/cinder-internal-tenant.html
Comment 5 lkuchlan 2016-02-03 03:53:45 EST
Tested using:
python-cinder-7.0.1-5.el7ost.noarch
openstack-cinder-7.0.1-5.el7ost.noarch
python-cinderclient-1.4.0-1.el7ost.noarch

[stack@instack ~]$ cinder create 1 --image 18234a00-1493-44b6-b6aa-5d78a500a752

From cinder db:

MariaDB [cinder]> select * from image_volume_cache_entries;
+---------------------+----+---------------------------------------------------------+--------------------------------------+--------------------------------------+------+---------------------+
| image_updated_at    | id | host                                                    | image_id                             | volume_id                            | size | last_used           |
+---------------------+----+---------------------------------------------------------+--------------------------------------+--------------------------------------+------+---------------------+
| 2016-01-27 20:45:08 |  1 | overcloud-controller-0.localdomain@Netapp1#vol_rhos_nfs | 2bc9560b-6e7c-4614-a332-3f263ed5fdc8 | c75409d8-dea2-401f-996e-e13cd6c98747 |    1 | 2016-02-03 08:43:27 |
+---------------------+----+---------------------------------------------------------+--------------------------------------+--------------------------------------+------+-------------------
Comment 7 errata-xmlrpc 2016-04-07 17:03:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.