Bug 1256513 - Support libipt for Broadwell+ Intel(R) Processor Trace
Support libipt for Broadwell+ Intel(R) Processor Trace
Status: CLOSED ERRATA
Product: Red Hat Developer Toolset
Classification: Red Hat
Component: gdb (Show other bugs)
DTS 4.0 RHEL 7
x86_64 Linux
unspecified Severity unspecified
: alpha
: 6.0
Assigned To: Jan Kratochvil
Sergey Kolosov
:
Depends On: 1270539
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-24 15:46 EDT by Jan Kratochvil
Modified: 2016-11-15 05:11 EST (History)
8 users (show)

See Also:
Fixed In Version: devtoolset-6-gdb-7.11.1-83.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-15 05:11:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2015-08-24 15:46:28 EDT
Description of problem:
DTS/Fedora/RHEL GDB does not yet support new functionality of branch tracing available in Broadwell + Skylake CPUs:
        https://sourceware.org/ml/gdb-patches/2015-07/msg00010.html
        http://post-office.corp.redhat.com/archives/debug-list/2015-August/msg00006.html

https://sourceware.org/gdb/onlinedocs/gdb/Process-Record-and-Replay.html
 - record btrace pt

To get the feature one could either package new rpm libipt or bundle libipt with GDB (either dynamically or statically). libipt will be a new Fedora package in Fedora Rawhide but that does not seem to be quick enough for DTS-4.0.

Version-Release number of selected component (if applicable):
devtoolset-4-gdb-7.9.90.20150717-7.el7

How reproducible:
Always.

Steps to Reproduce:
gdb -ex start -ex 'record btrace pt'

Actual results:
Target does not support branch tracing.

Expected results:
<nothing> ("info record" then should display PT is active)

Additional info:
Comment 2 Jan Kratochvil 2015-08-31 12:31:38 EDT
Fedora Rawhide libipt new package (.spec file) for review: Bug 1258572

So technically I can include it into DTS-4.0.
Comment 5 Jan Kratochvil 2015-09-04 14:14:08 EDT
gdb.rawhide+libipt.rawhide are built:
  https://koji.fedoraproject.org/koji/taskinfo?taskID=10944184 gdb.rawhide
  https://koji.fedoraproject.org/koji/buildinfo?buildID=682567 libipt.rawhide
Comment 7 Jan Kratochvil 2016-08-10 11:29:52 EDT
"intel_pt_interrupt" is still not found in:
  kernel-2.6.32-653.el6

But it is now present thanks to RHEL-7.3 kernel Bug 1270539 in:
  kernel-3.10.0-489.el7

It requires Intel Broadwell or higher where does exist:
  /sys/bus/event_source/devices/intel_pt/type
and also there is in CPU flags:
  grep -w intel_pt /proc/cpuinfo

Successfully tested it in Beaker with kernel-hw loaned machine:
  dell-per730-02.khw.lab.eng.bos.redhat.com
    kernel-3.10.0-489.el7.x86_64
Comment 15 errata-xmlrpc 2016-11-15 05:11:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2737.html

Note You need to log in before you can comment on or make changes to this bug.